Updates for new debian standards
[kmrcl.git] / debian / rules
index fa61826c78996f16eb30d4f17f0d60451f2852e7..9eb07146c2c3cdb61eb66c3e31a74fe08a9192f0 100755 (executable)
@@ -1,82 +1,60 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
 pkg    := kmrcl
-debpkg  := cl-kmrcl
-
+pkg-tests := $(pkg)-tests
+debpkg  := cl-$(pkg)
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-kmrcl      := $(clc-source)/$(pkg)
-
+clc-files      := $(clc-source)/$(pkg)
+clc-tests      := $(clc-source)/$(pkg-tests)
 doc-dir                := usr/share/doc/$(debpkg)
 
+tests-files    := tests.lisp
+source-files   := $(filter-out $(tests-files),$(wildcard *.lisp))
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
-
        touch configure-stamp
 
-
 build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-       # Add here commands to compile the package.
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       rm -f debian/cl-kmrcl.postinst.* debian/cl-kmrcl.prerm.*
+       rm -f debian/$(debpkg).postinst.* debian/$(debpkg).prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/kmrcl.
-       dh_installdirs $(clc-systems) $(clc-kmrcl) $(doc-dir)
-       dh_install kmrcl.asd $(shell echo *.lisp) $(clc-kmrcl)
-       dh_link $(clc-kmrcl)/kmrcl.asd $(clc-systems)/kmrcl.asd
+       dh_prep
+       dh_installdirs $(clc-systems) $(clc-files) $(clc-tests)
+       dh_install $(pkg).asd $(source-files) $(clc-files)
+       dh_link $(clc-files)/$(pkg).asd $(clc-systems)/$(pkg).asd
+       dh_install $(pkg-tests).asd $(tests-files) $(clc-tests)
+       dh_link $(clc-tests)/$(pkg-tests).asd $(clc-systems)/$(pkg-tests).asd
 
-# Build architecture-independent files here.
 binary-indep: build install
+       dh_testdir -i
+       dh_testroot -i
+       dh_installdocs -i
+       dh_installchangelogs -i ChangeLog
+       dh_strip -i
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdeb -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
 
-
-# Build architecture-dependent files here.
 binary-arch: build install
-       dh_testdir
-       dh_testroot
-#      dh_installdebconf       
-       dh_installdocs
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure
-