r9592: ready for boa
[lml.git] / 2 / debian / rules
1 #!/usr/bin/make -f
2
3 pkg     := lml2
4 debpkg  := cl-lml2
5
6 clc-source      := usr/share/common-lisp/source
7 clc-systems     := usr/share/common-lisp/systems
8 clc-lml2        := $(clc-source)/$(pkg)
9
10 doc-dir         := usr/share/doc/$(debpkg)
11
12 configure: configure-stamp
13 configure-stamp:
14         dh_testdir
15         # Add here commands to configure the package.
16         touch configure-stamp
17
18
19 build: build-stamp
20
21 build-stamp: configure-stamp 
22         dh_testdir
23         # Add here commands to compile the package.
24         touch build-stamp
25
26 clean:
27         dh_testdir
28         dh_testroot
29         rm -f build-stamp configure-stamp
30         # Add here commands to clean up after the build process.
31         rm -f debian/cl-lml2.postinst.* debian/cl-lml2.prerm.*
32         dh_clean
33
34 install: build
35         dh_testdir
36         dh_testroot
37         dh_clean -k
38         # Add here commands to install the package into debian/lml2.
39         dh_installdirs $(clc-systems) $(clc-lml2) $(doc-dir)
40         dh_install lml2.asd $(shell echo *.lisp) $(clc-lml2)
41         dh_link $(clc-lml2)/lml2.asd $(clc-systems)/lml2.asd
42
43 # Build architecture-independent files here.
44 binary-indep: build install
45
46
47 # Build architecture-dependent files here.
48 binary-arch: build install
49         dh_testdir
50         dh_testroot
51 #       dh_installdebconf       
52         dh_installdocs doc/readme.html
53         dh_installexamples doc/Makefile doc/make.lisp $(shell echo doc/*.lml)
54 #       dh_installmenu
55 #       dh_installlogrotate
56 #       dh_installemacsen
57 #       dh_installpam
58 #       dh_installmime
59 #       dh_installinit
60 #       dh_installcron
61 #       dh_installman
62 #       dh_installinfo
63 #       dh_undocumented
64         dh_installchangelogs ChangeLog
65         dh_strip
66         dh_compress
67         dh_fixperms
68 #       dh_makeshlibs
69         dh_installdeb
70 #       dh_perl
71         dh_shlibdeps
72         dh_gencontrol
73         dh_md5sums
74         dh_builddeb
75
76 binary: binary-indep binary-arch
77 .PHONY: build clean binary-indep binary-arch binary install configure
78