Merge branch 'master' of ssh://git.b9.com/home/gitpub/lml2
[lml2.git] / debian / rules
index ff93e37763662afe73cf93b169eaf1e11daf6e6a..cc4f062426b2b223383c91da7a2504a81521bd71 100755 (executable)
@@ -1,79 +1,45 @@
 #!/usr/bin/make -f
 
 #!/usr/bin/make -f
 
-pkg    := lml2
-debpkg  := cl-lml2
+pkg            := lml2
+debpkg         := cl-lml2
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-lml2       := $(clc-source)/$(pkg)
+clc-files      := $(clc-source)/$(pkg)
 
 
-doc-dir                := usr/share/doc/$(debpkg)
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-       touch configure-stamp
 
 
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-       # Add here commands to compile the package.
-       touch build-stamp
+build:
 
 clean:
        dh_testdir
        dh_testroot
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       rm -f debian/cl-lml2.postinst.* debian/cl-lml2.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/lml2.
-       dh_installdirs $(clc-systems) $(clc-lml2) $(doc-dir)
-       dh_install lml2.asd lml2-tests.asd $(shell echo *.lisp) $(clc-lml2)
-       dh_link $(clc-lml2)/lml2.asd $(clc-systems)/lml2.asd
-       dh_link $(clc-lml2)/lml2-tests.asd $(clc-systems)/lml2-tests.asd
-
-# Build architecture-independent files here.
-binary-indep: build install
+       dh_prep
+       dh_installdirs
+       dh_install lml2.asd lml2-tests.asd $(clc-files)
+       dh_install *.lisp $(clc-files)
 
 
+binary-arch:
 
 
-# Build architecture-dependent files here.
-binary-arch: build install
+binary-indep: install
        dh_testdir
        dh_testroot
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
        dh_installdocs doc/readme.html
        dh_installdocs doc/readme.html
-       dh_installexamples doc/Makefile doc/make.lisp $(shell echo doc/*.lml)
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs ChangeLog
-       dh_strip
+       dh_installexamples doc/Makefile doc/make.lisp doc/*.lml
+       dh_installchangelogs
+       dh_lisp
        dh_compress
        dh_fixperms
        dh_compress
        dh_fixperms
-#      dh_makeshlibs
        dh_installdeb
        dh_installdeb
-#      dh_perl
-       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary: binary-indep
+
 
 
+.PHONY: build clean binary-arch binary-indep binary install