Automated commit for debian release 1.6.6-1
[lml2.git] / debian / rules
index c0a9dbeeb997fd379f8ee385d9330db579d00740..a73b2651a0fff7956c0b64a04afff8c9b2744c75 100755 (executable)
@@ -3,14 +3,12 @@
 pkg    := lml2
 debpkg  := cl-lml2
 
-
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
 clc-lml2       := $(clc-source)/$(pkg)
 
 doc-dir                := usr/share/doc/$(debpkg)
 
-
 configure: configure-stamp
 configure-stamp:
        dh_testdir
@@ -39,15 +37,14 @@ install: build
        dh_clean -k
        # Add here commands to install the package into debian/lml2.
        dh_installdirs $(clc-systems) $(clc-lml2) $(doc-dir)
-       dh_install lml2.asd $(shell echo *.lisp) $(clc-lml2)
+       dh_install lml2.asd lml2-tests.asd $(shell echo *.lisp) $(clc-lml2)
        dh_link $(clc-lml2)/lml2.asd $(clc-systems)/lml2.asd
+       dh_link $(clc-lml2)/lml2-tests.asd $(clc-systems)/lml2-tests.asd
+
+binary-arch: build install
 
 # Build architecture-independent files here.
 binary-indep: build install
-
-
-# Build architecture-dependent files here.
-binary-arch: build install
        dh_testdir
        dh_testroot
 #      dh_installdebconf       
@@ -76,5 +73,5 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+.PHONY: build clean binary-arch binary-indep binary install configure