Convert to dh-lisp; add Vcs-Browser
[lml2.git] / debian / rules
index 3ff626b0e8e580ee0765a4ec49db26e7232ef73b..cc4f062426b2b223383c91da7a2504a81521bd71 100755 (executable)
@@ -1,81 +1,45 @@
 #!/usr/bin/make -f
 
-pkg    := lml2
-debpkg  := cl-lml2
-
+pkg            := lml2
+debpkg         := cl-lml2
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-lml2       := $(clc-source)/$(pkg)
-
-doc-dir                := usr/share/doc/$(debpkg)
-
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-       touch configure-stamp
+clc-files      := $(clc-source)/$(pkg)
 
 
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-       # Add here commands to compile the package.
-       touch build-stamp
+build:
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       rm -f debian/cl-lml2.postinst.* debian/cl-lml2.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/lml2.
-       dh_installdirs $(clc-systems) $(clc-lml2) $(doc-dir)
-       dh_install lml2.asd $(shell echo *.lisp) $(clc-lml2)
-       dh_install $(shell echo doc/*.html) $(doc-dir)
-       dh_link $(clc-lml2)/lml2.asd $(clc-systems)/lml2.asd
+       dh_prep
+       dh_installdirs
+       dh_install lml2.asd lml2-tests.asd $(clc-files)
+       dh_install *.lisp $(clc-files)
 
-# Build architecture-independent files here.
-binary-indep: build install
+binary-arch:
 
-
-# Build architecture-dependent files here.
-binary-arch: build install
+binary-indep: install
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
-       dh_installdocs
-       dh_installexamples doc/Makefile doc/make.lisp $(shell echo doc/*.lml)
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
+       dh_installdocs doc/readme.html
+       dh_installexamples doc/Makefile doc/make.lisp doc/*.lml
        dh_installchangelogs
-       dh_strip
+       dh_lisp
        dh_compress
        dh_fixperms
-#      dh_makeshlibs
        dh_installdeb
-#      dh_perl
-       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary: binary-indep
+
 
+.PHONY: build clean binary-arch binary-indep binary install