Automated commit for upstream build of version 1.8.5
[md5.git] / debian / rules
index 72f0c710168dbe98c5870a19d5611178e6059403..49eb12a1e979e48f03db45db24ff704f80448167 100755 (executable)
@@ -1,59 +1,34 @@
 #!/usr/bin/make -f
 
-pkg    := md5
-debpkg  := cl-md5
-
+pkg            := md5
+debpkg         := cl-md5
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-md5        := $(clc-source)/$(pkg)
-
-doc-dir                := usr/share/doc/$(debpkg)
-
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
+clc-files      := $(clc-source)/$(pkg)
 
 
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-       # Add here commands to compile the package.
-       touch build-stamp
+build:
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       rm -f debian/cl-md5.postinst.* debian/cl-md5.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/md5.
-       dh_installdirs $(clc-systems) $(clc-md5)
-       dh_install md5.asd $(shell echo *.lisp) $(clc-md5)
-       dh_link $(clc-md5)/md5.asd $(clc-systems)/md5.asd
-
-# Build architecture-independent files here.
-binary-indep: build install
+       dh_prep
+       dh_installdirs
+       dh_install md5.asd $(clc-files)
+       dh_install *.lisp $(clc-files)
 
-
-# Build architecture-dependent files here.
-binary-arch: build install
+binary-indep: install
        dh_testdir
        dh_testroot
        dh_installdocs
        dh_installchangelogs
-       dh_strip
+       dh_lisp
        dh_compress
        dh_fixperms
        dh_installdeb
@@ -62,6 +37,9 @@ binary-arch: build install
        dh_md5sums
        dh_builddeb
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary-arch:
+
+binary: binary-indep
+
 
+.PHONY: build clean binary-indep binary-arch binary install