Fix location of source files in debian
[memstore.git] / debian / rules
index bd47a3df8e98d37ab264e26cf27884521316bed2..ee21ed1343c3af248784b524382740a5b058128a 100755 (executable)
@@ -1,16 +1,11 @@
 #!/usr/bin/make -f
 
 pkg            := memstore
-pkg-tests      := $(pkg)-tests
 debpkg         := cl-$(pkg)
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
 clc-files      := $(clc-source)/$(pkg)
-clc-tests      := $(clc-source)/$(pkg-tests)
-
-tests-files    := tests.lisp
-source-files   := $(filter-out $(tests-files),$(wildcard *.lisp))
 
 
 build: build-arch build-indep
@@ -29,8 +24,9 @@ install: build
        dh_testroot
        dh_prep
        dh_installdirs
-       dh_install $(pkg).asd $(source-files) $(clc-files)
-       dh_install $(pkg-tests).asd $(tests-files) $(clc-tests)
+       dh_install $(pkg).asd $(pkg)-tests.asd memcache.asd $(clc-systems)
+       dh_install src/*.lisp $(clc-source)/$(pkg)/src
+       dh_install memcache/*.lisp $(clc-source)/$(pkg)/memcache
 
 binary-indep: install
        dh_testdir