Add entrez package, not currently working
[pubmed.git] / debian / rules
index cf945d6ff6b48aba5532ba114454b8dcdfc20c8a..a10399d02c0f48e38de242628c4d11009d441f1e 100755 (executable)
@@ -1,66 +1,43 @@
 #!/usr/bin/make -f
 
-pkg    := pubmed
-debpkg  := cl-pubmed
+pkg            := entrez
+debpkg         := cl-entrez
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-pubmed     := $(clc-source)/$(pkg)
+clc-files      := $(clc-source)/$(pkg)
 
-doc-dir                := usr/share/doc/$(debpkg)
-
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-       # Add here commands to compile the package.
-       touch build-stamp
+build:
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       rm -f debian/cl-pubmed.postinst.* debian/cl-pubmed.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/pubmed.
-       dh_installdirs $(clc-systems) $(clc-pubmed)
-       dh_install pubmed.asd $(shell echo *.lisp) $(clc-pubmed)
-       dh_link $(clc-pubmed)/pubmed.asd $(clc-systems)/pubmed.asd
-
-# Build architecture-independent files here.
-binary-indep: build install
+       dh_prep
+       dh_installdirs
+       dh_install entrez.asd $(clc-files)
+       dh_install *.lisp $(clc-files)
 
-
-# Build architecture-dependent files here.
-binary-arch: build install
+binary-indep: install
        dh_testdir
        dh_testroot
        dh_installdocs
        dh_installchangelogs
-       dh_strip
+       dh_lisp
        dh_compress
        dh_fixperms
        dh_installdeb
-       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary-arch:
+
+binary: binary-indep
+
 
+.PHONY: build clean binary-indep binary-arch binary install