r3220: *** empty log message ***
[reversi.git] / -clim / debian / rules
1 #!/usr/bin/make -f
2
3 export DH_COMPAT=4
4
5 pkg     := cl-reversi-clim
6
7
8 configure: configure-stamp
9 configure-stamp:
10         dh_testdir
11         # Add here commands to configure the package.
12
13         touch configure-stamp
14
15
16 build: build-stamp
17
18 build-stamp: configure-stamp 
19         dh_testdir
20         # Add here commands to compile the package.
21         lw-console -init lw-build-exec.lisp
22         touch build-stamp
23
24 clean:
25         dh_testdir
26         dh_testroot
27         rm -f build-stamp configure-stamp
28         # Add here commands to clean up after the build process.
29         rm -f debian/cl-reversi-clim.postinst.* debian/cl-reversi-clim.prerm.*
30         dh_clean
31
32 install: build
33         dh_testdir
34         dh_testroot
35         dh_clean -k
36         # Add here commands to install the package into debian/reversi.
37         dh_installdirs usr/bin
38         dh_install cl-reversi usr/bin
39
40 # Build architecture-independent files here.
41 binary-indep: build install
42
43
44 # Build architecture-dependent files here.
45 binary-arch: build install
46         dh_testdir
47         dh_testroot
48         dh_installdocs
49         dh_installchangelogs
50         dh_installman cl-reversi.1
51         dh_strip
52         dh_compress
53         dh_fixperms
54         dh_installdeb
55         dh_shlibdeps
56         dh_gencontrol
57         dh_md5sums
58         dh_builddeb
59
60 binary: binary-indep binary-arch
61 .PHONY: build clean binary-indep binary-arch binary install configure