r10646: updates
[reversi.git] / -clim / debian / rules
1 #!/usr/bin/make -f
2
3 pkg     := cl-reversi-clim
4
5
6 configure: configure-stamp
7 configure-stamp:
8         dh_testdir
9         # Add here commands to configure the package.
10
11         touch configure-stamp
12
13
14 build: build-stamp
15
16 build-stamp: configure-stamp 
17         dh_testdir
18         # Add here commands to compile the package.
19         lw-console -init lw-build-exec.lisp
20         touch build-stamp
21
22 clean:
23         dh_testdir
24         dh_testroot
25         rm -f build-stamp configure-stamp
26         # Add here commands to clean up after the build process.
27         rm -f debian/cl-reversi-clim.postinst.* debian/cl-reversi-clim.prerm.*
28         dh_clean
29
30 install: build
31         dh_testdir
32         dh_testroot
33         dh_clean -k
34         # Add here commands to install the package into debian/reversi.
35         dh_installdirs usr/bin
36         dh_install cl-reversi usr/bin
37
38 # Build architecture-independent files here.
39 binary-indep: build install
40
41
42 # Build architecture-dependent files here.
43 binary-arch: build install
44         dh_testdir
45         dh_testroot
46         dh_installdocs
47         dh_installchangelogs
48         dh_installman cl-reversi.1
49         #dh_strip  # This breaks lispworks executables
50         dh_compress
51         dh_fixperms
52         dh_installdeb
53         dh_shlibdeps
54         dh_gencontrol
55         dh_md5sums
56         dh_builddeb
57
58 binary: binary-indep binary-arch
59 .PHONY: build clean binary-indep binary-arch binary install configure