Update domain name to kpe.io
[vcs-tree.git] / debian / rules
index f9f80d2e639764ff35f25b80651e7daaebb1969e..3585ac80dbbcf279d28d671b2e3fc31fc5950dda 100755 (executable)
@@ -2,32 +2,19 @@
 
 pkg    := vcs-tree
 debpkg  := vcs-tree
-
-
-bin-dir                := usr/bin
-doc-dir                := usr/share/doc/$(debpkg)
-
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-       touch configure-stamp
-
+bin-dir        := usr/bin
 
 build: build-stamp
 
-build-stamp: configure-stamp 
+build-stamp:
        dh_testdir
-       # Add here commands to compile the package.
-       $(MAKE) ${pkg}
+       $(MAKE) _${pkg}
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
        $(MAKE) clean
        rm -f debian/${debpkg}.postinst.* debian/${debpkg}.prerm.*
        dh_clean
@@ -35,44 +22,32 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/xlunit.
+       dh_prep
        dh_installdirs $(bin-dir)
-       dh_install ${pkg} $(bin-dir)
+       dh_install $(pkg) $(bin-dir)
+       dh_install _$(pkg) $(bin-dir)
 
-# Build architecture-independent files here.
-binary-indep: build install
+binary-indep:
 
-
-# Build architecture-dependent files here.
-binary-arch: build install
+binary-arch: install
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
        dh_installdocs 
        dh_installexamples
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-       dh_installman ${pkg}.1
-#      dh_installinfo
-#      dh_undocumented
+       dh_installman $(pkg).1
+       dh_link usr/share/man/man1/$(pkg).1 usr/share/man/man1/_$(pkg).1
        dh_installchangelogs 
-       dh_strip
+       # don't strip sbcl binary or will remove vcs-tree code
+       dh_strip -X_$(pkg)
        dh_compress
        dh_fixperms
-#      dh_makeshlibs
        dh_installdeb
-#      dh_perl
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary: binary-arch
+
 
+.PHONY: build clean binary-indep binary-arch binary install