r11233: convert from sb-executable to save-lisp-and-die
[vcs-tree.git] / debian / rules
index f9f80d2e639764ff35f25b80651e7daaebb1969e..c97a2f6213bba5cf52f5b69432d567cae7697852 100755 (executable)
@@ -7,7 +7,6 @@ debpkg  := vcs-tree
 bin-dir                := usr/bin
 doc-dir                := usr/share/doc/$(debpkg)
 
-
 configure: configure-stamp
 configure-stamp:
        dh_testdir
@@ -20,7 +19,7 @@ build: build-stamp
 build-stamp: configure-stamp 
        dh_testdir
        # Add here commands to compile the package.
-       $(MAKE) ${pkg}
+       $(MAKE) _${pkg}
        touch build-stamp
 
 clean:
@@ -38,7 +37,8 @@ install: build
        dh_clean -k
        # Add here commands to install the package into debian/xlunit.
        dh_installdirs $(bin-dir)
-       dh_install ${pkg} $(bin-dir)
+       dh_install $(pkg) $(bin-dir)
+       dh_install _$(pkg) $(bin-dir)
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -58,11 +58,12 @@ binary-arch: build install
 #      dh_installmime
 #      dh_installinit
 #      dh_installcron
-       dh_installman ${pkg}.1
+       dh_installman $(pkg).1
 #      dh_installinfo
 #      dh_undocumented
        dh_installchangelogs 
-       dh_strip
+       # don't strip sbcl binary or will remove vcs-tree code
+       dh_strip -X_$(pkg)
        dh_compress
        dh_fixperms
 #      dh_makeshlibs