Updates for new debian standards
[wdq2wav.git] / debian / rules
index 5c8f9b798399a60cdacc97c6cfa9c6becb82ddde..93db31340be0c6ef99c7bf259455bb4ff96f9b6b 100755 (executable)
@@ -1,9 +1,4 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
 
 CFLAGS = -Wall -g
 
@@ -19,8 +14,6 @@ endif
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
-
        touch configure-stamp
 
 
@@ -28,19 +21,13 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-
-       # Add here commands to compile the package.
        $(MAKE)
-       #/usr/bin/docbook-to-man debian/wdq2wav.sgml > wdq2wav.1
-
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-
-       # Add here commands to clean up after the build process.
        $(MAKE) clean
 
        dh_clean
@@ -48,42 +35,27 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
-
-       # Add here commands to install the package into debian/wdq2wav.
        $(MAKE) install DESTDIR=$(CURDIR)/debian/wdq2wav
 
-
-# Build architecture-independent files here.
 binary-indep: build install
-# We have nothing to do by default.
 
-# Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
        dh_installdocs
        dh_installexamples
        dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
        dh_installcron
        dh_installman
        dh_installinfo
-#      dh_undocumented
        dh_installchangelogs 
        dh_link
        dh_strip
        dh_compress
        dh_fixperms
-#      dh_makeshlibs
        dh_installdeb
-#      dh_perl
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums