Fix signed integer warning; debian build hardening
[wdq2wav.git] / debian / rules
index 3cb75fad08b19e585ec57de4c981376c1d092f7b..d3f0854748ce31f1310896623b42f7c580099931 100755 (executable)
@@ -1,14 +1,4 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=4
-
-
 
 CFLAGS = -Wall -g
 
@@ -21,78 +11,69 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
        INSTALL_PROGRAM += -s
 endif
 
+export DEB_BUILD_HARDENING=1
+export DPKG_EXPORT_BUILDFLAGS=1
+export DEB_BUILD_MAINT_OPTIONS="hardening=+all" 
+CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
+CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
+CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
+LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
+
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
-
        touch configure-stamp
 
 
-build: build-stamp
+build: build-stamp build-arch build-indep
 
-build-stamp: configure-stamp 
+build-stamp: configure-stamp
        dh_testdir
-
-       # Add here commands to compile the package.
        $(MAKE)
-       #/usr/bin/docbook-to-man debian/wdq2wav.sgml > wdq2wav.1
-
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-
-       # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-
+       $(MAKE) clean
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
+       DPKG_EXPORT_BUILDFLAGS=1
+       $(MAKE)
+       dh_install wdq2wav usr/bin
 
-       # Add here commands to install the package into debian/wdq2wav.
-       $(MAKE) install DESTDIR=$(CURDIR)/debian/wdq2wav
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
+binary-indep: 
 
-# Build architecture-dependent files here.
-binary-arch: build install
+binary-arch: install
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
        dh_installdocs
        dh_installexamples
        dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
        dh_installcron
-       dh_installman
+       dh_installman wdq2wav.1
        dh_installinfo
-#      dh_undocumented
        dh_installchangelogs 
        dh_link
        dh_strip
        dh_compress
        dh_fixperms
-#      dh_makeshlibs
        dh_installdeb
-#      dh_perl
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-binary: binary-indep binary-arch
+build-indep:
+
+build-arch:
+
+binary: clean binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure