Updates for new debian standards
[xptest.git] / debian / rules
index de6a977cfafc8a218a9378167ab3a17f478e9965..56593b26a14d60350088c8a4b63a13b127eeb37c 100755 (executable)
@@ -6,15 +6,11 @@ debpkg  := cl-xptest
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
 clc-xptest     := $(clc-source)/$(pkg)
-
 doc-dir                := usr/share/doc/$(debpkg)
 
-
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
-
        touch configure-stamp
 
 
@@ -22,45 +18,38 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-       # Add here commands to compile the package.
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
        rm -f debian/cl-xptest.postinst.* debian/cl-xptest.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/xptest.
+       dh_prep
        dh_installdirs $(clc-systems) $(clc-xptest)
        dh_install xptest.asd xptestsuite.lisp $(clc-xptest)
        dh_link $(clc-xptest)/xptest.asd $(clc-systems)/xptest.asd
 
-# Build architecture-independent files here.
 binary-indep: build install
+       dh_testdir -i
+       dh_testroot -i
+       dh_installdocs -i
+       dh_installexamples -i xptest-example.lisp
+       dh_installchangelogs -i
+       dh_strip -i
+       dh_compress -i
+       dh_fixperms -i
+       dh_installdeb -i
+       dh_gencontrol -i
+       dh_md5sums -i
+       dh_builddeb -i
 
-
-# Build architecture-dependent files here.
 binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs
-       dh_installexamples xptest-example.lisp
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install configure