Update domain name to kpe.io
[xptest.git] / debian / rules
index f8e96ec9050328ce81f127748e1f6c892b0bbd28..7ac0347eba09a4e044b1c4e8e3cd1f2178868c43 100755 (executable)
@@ -1,68 +1,44 @@
 #!/usr/bin/make -f
 
-pkg    := xptest
-debpkg  := cl-xptest
-
+pkg            := xptest
+debpkg         := cl-xptest
 
 clc-source     := usr/share/common-lisp/source
 clc-systems    := usr/share/common-lisp/systems
-clc-xptest     := $(clc-source)/$(pkg)
-
-doc-dir                := usr/share/doc/$(debpkg)
-
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
+clc-files      := $(clc-source)/$(pkg)
 
 
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-       # Add here commands to compile the package.
-       touch build-stamp
+build:
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       rm -f debian/cl-xptest.postinst.* debian/cl-xptest.prerm.*
        dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/xptest.
-       dh_installdirs $(clc-systems) $(clc-xptest)
-       dh_install xptest.asd xptestsuite.lisp $(clc-xptest)
-       dh_link $(clc-xptest)/xptest.asd $(clc-systems)/xptest.asd
+       dh_prep
+       dh_installdirs
+       dh_install $(pkg).asd xptestsuite.lisp $(clc-files)
 
-# Build architecture-independent files here.
 binary-indep: build install
-
-
-# Build architecture-dependent files here.
-binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installdocs
        dh_installexamples xptest-example.lisp
        dh_installchangelogs
-       dh_strip
+       dh_lisp
        dh_compress
        dh_fixperms
        dh_installdeb
-       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary-arch:
+
+binary: binary-indep
+
 
+.PHONY: build clean binary-indep binary-arch binary install