remove files from umlisp-orf package
[umlisp.git] / -orf / debian / rules
diff --git a/-orf/debian/rules b/-orf/debian/rules
deleted file mode 100755 (executable)
index 11488d2..0000000
+++ /dev/null
@@ -1,81 +0,0 @@
-#!/usr/bin/make -f
-
-pkg    := umlisp-orf
-debpkg  := cl-umlisp-orf
-
-
-clc-source     := usr/share/common-lisp/source
-clc-systems    := usr/share/common-lisp/systems
-clc-umlisp-orf := $(clc-source)/$(pkg)
-
-doc-dir                := usr/share/doc/$(debpkg)
-
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-       # Add here commands to compile the package.
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       rm -f debian/cl-umlisp-orf.postinst.* debian/cl-umlisp-orf.prerm.*
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       # Add here commands to install the package into debian/umlisp-orf.
-       dh_installdirs $(clc-systems) $(clc-umlisp-orf) $(doc-dir)
-       dh_install umlisp-orf.asd $(shell echo *.lisp) $(clc-umlisp-orf)
-       #dh_install $(shell echo *.html) $(doc-dir)
-       dh_link $(clc-umlisp-orf)/umlisp-orf.asd $(clc-systems)/umlisp-orf.asd
-
-# Build architecture-independent files here.
-binary-indep: build install
-
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-#      dh_installdebconf       
-       dh_installdocs
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
-