948cf19fef08183930c812ce57147e65e283eb52
[ctsim.git] / rpm / ctsim-2.0.0b9-1.spec
1 # Version of CTSim
2 %define version 2.0.0b8
3
4 Summary: CTSim - Open-Source Computed Tomography Simulator
5 Name: ctsim
6 Version: %{version}
7 Release: 1
8 Packager: Kevin Rosenberg <kevin@rosenberg.net>
9 Source: ftp.ctsim.org:/pub/ctsim/ctsim-%{version}.tar.gz
10 Copyright: GPL
11 Group: Applications/Scientific
12
13 %description
14 CTSim is a Computed Tomography Simulator.
15
16 %prep
17 %setup 
18
19 %build
20 CFLAGS="$RPM_OPT_FLAGS" \
21         ./configure --prefix=/usr/local
22 make
23
24 %install
25 install -s -m 755 -o 0 -g 0 src/ctsim /usr/local/bin/ctsim
26 install -s -m 755 -o 0 -g 0 tools/pjrec /usr/local/bin/pjrec
27 install -s -m 755 -o 0 -g 0 tools/pj2if /usr/local/bin/pj2if
28 install -s -m 755 -o 0 -g 0 tools/phm2pj /usr/local/bin/phm2pj
29 install -s -m 755 -o 0 -g 0 tools/phm2if /usr/local/bin/phm2if
30 install -s -m 755 -o 0 -g 0 tools/if-1 /usr/local/bin/if-1
31 install -s -m 755 -o 0 -g 0 tools/if-2 /usr/local/bin/if-2
32 install -s -m 755 -o 0 -g 0 tools/if2img /usr/local/bin/if2img
33 install -s -m 755 -o 0 -g 0 tools/if-1 /usr/local/bin/ifinfo
34 install -m 755 -o 0 -g 0 tools/sample-ctsim.sh /usr/local/bin/sample-ctsim.sh
35
36 %files
37 %doc README COPYING ChangeLog INSTALL
38
39 /usr/local/bin/ctsim
40 /usr/local/bin/pjrec
41 /usr/local/bin/pj2if
42 /usr/local/bin/phm2pj
43 /usr/local/bin/phm2if
44 /usr/local/bin/if-1
45 /usr/local/bin/if-2
46 /usr/local/bin/if2img
47 /usr/local/bin/ifinfo
48 /usr/local/bin/sample-ctsim.sh
49
50