r10517: Automated commit for Debian build of ctsim upstream-version-4.3.2
[ctsim.git] / debian / rules
index 6627b158275cfa673c6d15341357d81158e3bc24..15a1176a6a9ec4b8ffd22bf466d40f842e18f790 100755 (executable)
@@ -34,7 +34,10 @@ pixmap-dir   := usr/share/pixmaps
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
+        touch configure.in && \
+        touch aclocal.m4 && \
+        touch configure
+
        ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
        touch configure-stamp
 
@@ -66,6 +69,11 @@ clean:
        -$(MAKE) distclean
        find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
+       # Ensure up-to-date versions of config.sub and config.guess
+        -test -r /usr/share/misc/config.sub && \
+           cp -f /usr/share/misc/config.sub config.sub
+        -test -r /usr/share/misc/config.guess && \
+           cp -f /usr/share/misc/config.guess config.guess
        dh_clean
 
 install: DH_OPTIONS=