r11769: remove pentium4 optimized version
[ctsim.git] / debian / rules
index c5abb0075f0f0e5454b75e0669c1a6dd9aebd1eb..164c1ebdec88e9d71df06f3c3be776b9dd5db6a8 100755 (executable)
@@ -10,33 +10,27 @@ endif
 host_arch      := $(shell dpkg-architecture -qDEB_HOST_ARCH)
 
 pkg            := ctsim
-pkg-p4         := ctsim-pentium4
-pkg-athlon     := ctsim-athlon
 pkg-help       := ctsim-help
 pkg-doc                := ctsim-doc
 
 ctsim-shared   := usr/share/ctsim
 
 prefix         := debian/$(pkg)
-prefix-p4      := debian/$(pkg-p4)
-prefix-athlon  := debian/$(pkg-athlon)
 prefix-help    := debian/$(pkg-help)
 prefix-doc     := debian/$(pkg-doc)
 
 DESTDIR                := `pwd`/$(prefix)
-DESTDIR-P4     := `pwd`/$(prefix-p4)
-DESTDIR-ATHLON := `pwd`/$(prefix-athlon)
 HELPDIR                := `pwd`/$(prefix-help)/$(ctsim-shared)
 doc-dir                := usr/share/doc/$(pkg-doc)
 pixmap-dir     := usr/share/pixmaps
-
+desktop-dir    := usr/share/applications
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
        touch configure.in && touch aclocal.m4 && touch configure
 
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn -with-x
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn -with-x --without-lam
        touch configure-stamp
 
 
@@ -63,8 +57,7 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-arch-stamp build-indep-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       -$(MAKE) distclean
+       if [ -f Makefile ]; then $(MAKE) clean; fi
        find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
        # Ensure up-to-date versions of config.sub and config.guess
@@ -81,28 +74,10 @@ install: build
        #
        dh_installdirs -p $(pkg-help) $(ctsim-shared)
        ${MAKE} install
-       # Testing for i386 optimized builds
-       echo Host architecture is $(host_arch)
-ifneq (,$(findstring i386,$(host_arch)))
-       # Building CPU-specific i386 flavors
-       # Pentium 4
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
-       $(MAKE) all
-       ${MAKE} install
-       # Athlon
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
-       $(MAKE) all
-       ${MAKE} install
-       dh_installdirs -p $(pkg-p4) $(pixmap-dir)
-       dh_installdirs -p $(pkg-athlon) $(pixmap-dir)
-       dh_install -p $(pkg-p4) debian/ctsim.xpm $(pixmap-dir)
-       dh_install -p $(pkg-athlon) debian/ctsim.xpm $(pixmap-dir)
-endif
-       # Add here commands to install the package into debian/ctsim.
        dh_installdirs -p $(pkg) $(pixmap-dir)
+       dh_installdirs -p $(pkg) $(desktop-dir)
        dh_install -p $(pkg) debian/ctsim.xpm $(pixmap-dir)
+       dh_install -p $(pkg) debian/ctsim.desktop $(desktop-dir)
        dh_install -p $(pkg-help) docs/ctsim.htb $(ctsim-shared)
        dh_install -p $(pkg-doc) docs/html $(doc-dir)
        dh_link -p $(pkg-doc) $(doc-dir)/html/$(pkg)_contents.html $(doc-dir)/html/index.html
@@ -111,7 +86,6 @@ endif
        gunzip docs/ctsim.pdf.gz
        chmod +x helical/*.sh tools/*.sh
 
-# Build architecture-independent files here.
 # Pass -i to all debhelper commands in this target to reduce clutter.
 binary-indep: build install
        dh_testdir -i
@@ -136,24 +110,6 @@ binary-arch: build install
        dh_testroot -a
        dh_installdocs -a
        dh_installexamples -p $(pkg) tools/sample-ctsim.sh helical/sample-helical.sh
-ifneq (,$(findstring i386,$(host_arch)))
-       dh_installexamples -p $(pkg-p4) tools/sample-ctsim.sh helical/sample-helical.sh
-       dh_installexamples -p $(pkg-athlon) tools/sample-ctsim.sh helical/sample-helical.sh
-endif
-
-ifeq (,$(findstring i386,$(host_arch)))
-       dh_installchangelogs -p $(pkg)ChangeLog 
-       dh_strip -p $(pkg)
-       dh_link -p $(pkg)
-       dh_compress -p $(pkg)
-       dh_fixperms -p $(pkg)
-       dh_installmenu -p $(pkg)
-       dh_installdeb -p $(pkg)
-       dh_gencontrol -p $(pkg)
-       dh_shlibdeps -p $(pkg)
-       dh_md5sums -p $(pkg)
-       dh_builddeb -p $(pkg)
-else
        dh_installchangelogs ChangeLog -a
        dh_strip -a
        dh_link -a
@@ -165,9 +121,7 @@ else
        dh_shlibdeps -a
        dh_md5sums -a
        dh_builddeb -a
-endif
 
 binary: binary-indep binary-arch
 
 .PHONY: build clean binary-indep binary-arch binary install configure
-