r3894: Automatic commit for debian_version_4_1_0-1
[ctsim.git] / debian / rules
index 90008fd3ff1cbb97a92ce55992a7882e49453805..1aa20200bd83d88fe36a939fede7211c6ea40e07 100755 (executable)
@@ -2,6 +2,15 @@
 
 export DH_COMPAT=4
 
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -g
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+       INSTALL_PROGRAM += -s
+endif
+
+host_arch      := $(dpkg-architecture -qDEB_HOST_ARCH)
+
 pkg            := ctsim
 pkg-p4         := ctsim-pentium4
 pkg-athlon     := ctsim-athlon
@@ -23,6 +32,7 @@ HELPDIR               := `pwd`/$(prefix-help)/$(ctsim-shared)
 doc-dir                := usr/share/doc/$(pkg-doc)
 pixmap-dir     := usr/X11R6/include/X11/pixmaps
 
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
@@ -34,18 +44,6 @@ build-arch: configure-stamp build-arch-stamp
 build-arch-stamp:
        dh_testdir
        # Add here commands to compile the package.
-       dh_installdirs -p $(pkg-help) $(ctsim-shared)
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
-       $(MAKE) all
-       ${MAKE} install
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --mcpu=pentium4
-       $(MAKE) all
-       ${MAKE} install
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --mcpu=athlon
-       $(MAKE) all
-       ${MAKE} install
        touch build-arch-stamp
 
 build-indep: configure-stamp  build-indep-stamp
@@ -76,9 +74,30 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
+       #
+       dh_installdirs -p $(pkg-help) $(ctsim-shared)
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
+       $(MAKE) all
+       ${MAKE} install
+ifeq ($(host_arch),i386)
+       # Pentium 4
+       ${MAKE} clean
+       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
+       $(MAKE) all
+       ${MAKE} install
+       # Athlon
+       ${MAKE} clean
+       ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
+       $(MAKE) all
+       ${MAKE} install
+endif
        # Add here commands to install the package into debian/ctsim.
-       dh_installdirs -p $(pkg-help) $(pixmap-dir)
-       dh_install -p $(pkg-help) debian/ctsim.xpm $(pixmap-dir)
+       dh_installdirs -p $(pkg) $(pixmap-dir)
+       dh_installdirs -p $(pkg-p4) $(pixmap-dir)
+       dh_installdirs -p $(pkg-athlon) $(pixmap-dir)
+       dh_install -p $(pkg) debian/ctsim.xpm $(pixmap-dir)
+       dh_install -p $(pkg-p4) debian/ctsim.xpm $(pixmap-dir)
+       dh_install -p $(pkg-athlon) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-help) docs/ctsim.htb $(ctsim-shared)
        dh_install -p $(pkg-doc) docs/html $(doc-dir)
        dh_link -p $(pkg-doc) $(doc-dir)/html/$(pkg)_contents.html $(doc-dir)/html/index.html