r3894: Automatic commit for debian_version_4_1_0-1
[ctsim.git] / debian / rules
index 96f290dadaeb3ee3176270bc953917451d07a8c3..1aa20200bd83d88fe36a939fede7211c6ea40e07 100755 (executable)
@@ -2,12 +2,23 @@
 
 export DH_COMPAT=4
 
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -g
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+       INSTALL_PROGRAM += -s
+endif
+
+host_arch      := $(dpkg-architecture -qDEB_HOST_ARCH)
+
 pkg            := ctsim
 pkg-p4         := ctsim-pentium4
 pkg-athlon     := ctsim-athlon
 pkg-help       := ctsim-help
 pkg-doc                := ctsim-doc
 
+ctsim-shared   := usr/share/ctsim
+
 prefix         := debian/$(pkg)
 prefix-p4      := debian/$(pkg-p4)
 prefix-athlon  := debian/$(pkg-athlon)
@@ -17,10 +28,11 @@ prefix-doc  := debian/$(pkg-doc)
 DESTDIR                := `pwd`/$(prefix)
 DESTDIR-P4     := `pwd`/$(prefix-p4)
 DESTDIR-ATHLON := `pwd`/$(prefix-athlon)
-HELPDIR                := `pwd`/$(prefix-help)/usr/share/ctsim
+HELPDIR                := `pwd`/$(prefix-help)/$(ctsim-shared)
 doc-dir                := usr/share/doc/$(pkg-doc)
 pixmap-dir     := usr/X11R6/include/X11/pixmaps
 
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
@@ -32,17 +44,6 @@ build-arch: configure-stamp build-arch-stamp
 build-arch-stamp:
        dh_testdir
        # Add here commands to compile the package.
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
-       $(MAKE) all
-       ${MAKE} install
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --mcpu=pentium4
-       $(MAKE) all
-       ${MAKE} install
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --mcpu=athlon
-       $(MAKE) all
-       ${MAKE} install
        touch build-arch-stamp
 
 build-indep: configure-stamp  build-indep-stamp
@@ -73,9 +74,31 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
+       #
+       dh_installdirs -p $(pkg-help) $(ctsim-shared)
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
+       $(MAKE) all
+       ${MAKE} install
+ifeq ($(host_arch),i386)
+       # Pentium 4
+       ${MAKE} clean
+       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
+       $(MAKE) all
+       ${MAKE} install
+       # Athlon
+       ${MAKE} clean
+       ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
+       $(MAKE) all
+       ${MAKE} install
+endif
        # Add here commands to install the package into debian/ctsim.
-       dh_installdirs -p $(pkg-help) $(pixmap-dir)
-       dh_install -p $(pkg-help) debian/ctsim.xpm $(pixmap-dir)
+       dh_installdirs -p $(pkg) $(pixmap-dir)
+       dh_installdirs -p $(pkg-p4) $(pixmap-dir)
+       dh_installdirs -p $(pkg-athlon) $(pixmap-dir)
+       dh_install -p $(pkg) debian/ctsim.xpm $(pixmap-dir)
+       dh_install -p $(pkg-p4) debian/ctsim.xpm $(pixmap-dir)
+       dh_install -p $(pkg-athlon) debian/ctsim.xpm $(pixmap-dir)
+       dh_install -p $(pkg-help) docs/ctsim.htb $(ctsim-shared)
        dh_install -p $(pkg-doc) docs/html $(doc-dir)
        dh_link -p $(pkg-doc) $(doc-dir)/html/$(pkg)_contents.html $(doc-dir)/html/index.html
        gzip -9 docs/ctsim.pdf