r10662: new upstream: 4.4.0. Changes to support X.org
[ctsim.git] / debian / rules
index 15a1176a6a9ec4b8ffd22bf466d40f842e18f790..21d0499f8c9a4043efc41fdb995065bda97a0076 100755 (executable)
@@ -34,11 +34,9 @@ pixmap-dir   := usr/share/pixmaps
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-        touch configure.in && \
-        touch aclocal.m4 && \
-        touch configure
+       touch configure.in && touch aclocal.m4 && touch configure
 
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn -with-x
        touch configure-stamp
 
 
@@ -70,10 +68,8 @@ clean:
        find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
        # Ensure up-to-date versions of config.sub and config.guess
-        -test -r /usr/share/misc/config.sub && \
-           cp -f /usr/share/misc/config.sub config.sub
-        -test -r /usr/share/misc/config.guess && \
-           cp -f /usr/share/misc/config.guess config.guess
+       -test -r /usr/share/misc/config.sub && cp -f /usr/share/misc/config.sub config.sub
+       -test -r /usr/share/misc/config.guess && cp -f /usr/share/misc/config.guess config.guess
        dh_clean
 
 install: DH_OPTIONS=