r10662: new upstream: 4.4.0. Changes to support X.org
[ctsim.git] / debian / rules
index 478e8110f2c0fda13f41677f7b9a7d5407620fa6..21d0499f8c9a4043efc41fdb995065bda97a0076 100755 (executable)
@@ -1,7 +1,5 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -g
 endif
@@ -13,7 +11,6 @@ host_arch     := $(shell dpkg-architecture -qDEB_HOST_ARCH)
 
 pkg            := ctsim
 pkg-p4         := ctsim-pentium4
-pkg-p3         := ctsim-pentium3
 pkg-athlon     := ctsim-athlon
 pkg-help       := ctsim-help
 pkg-doc                := ctsim-doc
@@ -22,25 +19,24 @@ ctsim-shared        := usr/share/ctsim
 
 prefix         := debian/$(pkg)
 prefix-p4      := debian/$(pkg-p4)
-prefix-p3      := debian/$(pkg-p3)
 prefix-athlon  := debian/$(pkg-athlon)
 prefix-help    := debian/$(pkg-help)
 prefix-doc     := debian/$(pkg-doc)
 
 DESTDIR                := `pwd`/$(prefix)
 DESTDIR-P4     := `pwd`/$(prefix-p4)
-DESTDIR-P3     := `pwd`/$(prefix-p3)
 DESTDIR-ATHLON := `pwd`/$(prefix-athlon)
 HELPDIR                := `pwd`/$(prefix-help)/$(ctsim-shared)
 doc-dir                := usr/share/doc/$(pkg-doc)
-pixmap-dir     := usr/X11R6/include/X11/pixmaps
+pixmap-dir     := usr/share/pixmaps
 
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
+       touch configure.in && touch aclocal.m4 && touch configure
+
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn -with-x
        touch configure-stamp
 
 
@@ -71,6 +67,9 @@ clean:
        -$(MAKE) distclean
        find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
+       # Ensure up-to-date versions of config.sub and config.guess
+       -test -r /usr/share/misc/config.sub && cp -f /usr/share/misc/config.sub config.sub
+       -test -r /usr/share/misc/config.guess && cp -f /usr/share/misc/config.guess config.guess
        dh_clean
 
 install: DH_OPTIONS=
@@ -86,11 +85,6 @@ install: build
        echo Host architecture is $(host_arch)
 ifneq (,$(findstring i386,$(host_arch)))
        # Building CPU-specific i386 flavors
-       # Pentium 3
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-P3)/usr --mandir=$(DESTDIR-P3)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium3
-       $(MAKE) all
-       ${MAKE} install
        # Pentium 4
        ${MAKE} clean
        ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
@@ -101,10 +95,8 @@ ifneq (,$(findstring i386,$(host_arch)))
        ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
        $(MAKE) all
        ${MAKE} install
-       dh_installdirs -p $(pkg-p3) $(pixmap-dir)
        dh_installdirs -p $(pkg-p4) $(pixmap-dir)
        dh_installdirs -p $(pkg-athlon) $(pixmap-dir)
-       dh_install -p $(pkg-p3) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-p4) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-athlon) debian/ctsim.xpm $(pixmap-dir)
 endif
@@ -155,7 +147,6 @@ binary-arch: build install
        dh_installdocs -a
        dh_installexamples -p $(pkg) tools/sample-ctsim.sh helical/sample-helical.sh
 ifneq (,$(findstring i386,$(host_arch)))
-       dh_installexamples -p $(pkg-p3) tools/sample-ctsim.sh helical/sample-helical.sh
        dh_installexamples -p $(pkg-p4) tools/sample-ctsim.sh helical/sample-helical.sh
        dh_installexamples -p $(pkg-athlon) tools/sample-ctsim.sh helical/sample-helical.sh
 endif