r10662: new upstream: 4.4.0. Changes to support X.org
[ctsim.git] / debian / rules
index 7bfcfea8f151a08280d7e0d83ca4bbbd7062822d..21d0499f8c9a4043efc41fdb995065bda97a0076 100755 (executable)
@@ -34,8 +34,9 @@ pixmap-dir    := usr/share/pixmaps
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
+       touch configure.in && touch aclocal.m4 && touch configure
+
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn -with-x
        touch configure-stamp
 
 
@@ -66,6 +67,9 @@ clean:
        -$(MAKE) distclean
        find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
+       # Ensure up-to-date versions of config.sub and config.guess
+       -test -r /usr/share/misc/config.sub && cp -f /usr/share/misc/config.sub config.sub
+       -test -r /usr/share/misc/config.guess && cp -f /usr/share/misc/config.guess config.guess
        dh_clean
 
 install: DH_OPTIONS=
@@ -91,10 +95,8 @@ ifneq (,$(findstring i386,$(host_arch)))
        ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
        $(MAKE) all
        ${MAKE} install
-       dh_installdirs -p $(pkg-p3) $(pixmap-dir)
        dh_installdirs -p $(pkg-p4) $(pixmap-dir)
        dh_installdirs -p $(pkg-athlon) $(pixmap-dir)
-       dh_install -p $(pkg-p3) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-p4) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-athlon) debian/ctsim.xpm $(pixmap-dir)
 endif
@@ -145,7 +147,6 @@ binary-arch: build install
        dh_installdocs -a
        dh_installexamples -p $(pkg) tools/sample-ctsim.sh helical/sample-helical.sh
 ifneq (,$(findstring i386,$(host_arch)))
-       dh_installexamples -p $(pkg-p3) tools/sample-ctsim.sh helical/sample-helical.sh
        dh_installexamples -p $(pkg-p4) tools/sample-ctsim.sh helical/sample-helical.sh
        dh_installexamples -p $(pkg-athlon) tools/sample-ctsim.sh helical/sample-helical.sh
 endif