r10662: new upstream: 4.4.0. Changes to support X.org
[ctsim.git] / debian / rules
index 9d376e8cf97b02470471898400b8c9913ae82d62..21d0499f8c9a4043efc41fdb995065bda97a0076 100755 (executable)
@@ -1,7 +1,5 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -g
 endif
@@ -9,7 +7,7 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
        INSTALL_PROGRAM += -s
 endif
 
-host_arch      := $(dpkg-architecture -qDEB_HOST_ARCH)
+host_arch      := $(shell dpkg-architecture -qDEB_HOST_ARCH)
 
 pkg            := ctsim
 pkg-p4         := ctsim-pentium4
@@ -30,14 +28,15 @@ DESTDIR-P4  := `pwd`/$(prefix-p4)
 DESTDIR-ATHLON := `pwd`/$(prefix-athlon)
 HELPDIR                := `pwd`/$(prefix-help)/$(ctsim-shared)
 doc-dir                := usr/share/doc/$(pkg-doc)
-pixmap-dir     := usr/X11R6/include/X11/pixmaps
+pixmap-dir     := usr/share/pixmaps
 
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
+       touch configure.in && touch aclocal.m4 && touch configure
+
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn -with-x
        touch configure-stamp
 
 
@@ -68,6 +67,9 @@ clean:
        -$(MAKE) distclean
        find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
+       # Ensure up-to-date versions of config.sub and config.guess
+       -test -r /usr/share/misc/config.sub && cp -f /usr/share/misc/config.sub config.sub
+       -test -r /usr/share/misc/config.guess && cp -f /usr/share/misc/config.guess config.guess
        dh_clean
 
 install: DH_OPTIONS=
@@ -79,10 +81,10 @@ install: build
        #
        dh_installdirs -p $(pkg-help) $(ctsim-shared)
        ${MAKE} install
-       echo Testing for i386 optimized builds
+       # Testing for i386 optimized builds
        echo Host architecture is $(host_arch)
 ifneq (,$(findstring i386,$(host_arch)))
-       echo Building CPU-specific i386 flavors
+       # Building CPU-specific i386 flavors
        # Pentium 4
        ${MAKE} clean
        ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
@@ -143,29 +145,47 @@ binary-arch: build install
        dh_testroot -a
 #      dh_installdebconf -a
        dh_installdocs -a
-       dh_installexamples -a tools/sample-ctsim.sh helical/sample-helical.sh
-       dh_installmenu -a
+       dh_installexamples -p $(pkg) tools/sample-ctsim.sh helical/sample-helical.sh
+ifneq (,$(findstring i386,$(host_arch)))
+       dh_installexamples -p $(pkg-p4) tools/sample-ctsim.sh helical/sample-helical.sh
+       dh_installexamples -p $(pkg-athlon) tools/sample-ctsim.sh helical/sample-helical.sh
+endif
 #      dh_installlogrotate -a
 #      dh_installemacsen -a
 #      dh_installpam -a
 #      dh_installmime -a
 #      dh_installinit -a
-       dh_installcron -a
+#      dh_installcron -a
 #      dh_installman -a
-       dh_installinfo -a
+#      dh_installinfo -a
 #      dh_undocumented -a
+#      dh_makeshlibs -a
+#      dh_perl -a
+ifeq (,$(findstring i386,$(host_arch)))
+       dh_installchangelogs -p $(pkg)ChangeLog 
+       dh_strip -p $(pkg)
+       dh_link -p $(pkg)
+       dh_compress -p $(pkg)
+       dh_fixperms -p $(pkg)
+       dh_installmenu -p $(pkg)
+       dh_installdeb -p $(pkg)
+       dh_gencontrol -p $(pkg)
+       dh_shlibdeps -p $(pkg)
+       dh_md5sums -p $(pkg)
+       dh_builddeb -p $(pkg)
+else
        dh_installchangelogs ChangeLog -a
        dh_strip -a
        dh_link -a
        dh_compress -a
        dh_fixperms -a
-#      dh_makeshlibs -a
+       dh_installmenu -a
        dh_installdeb -a
-#      dh_perl -a
-       dh_shlibdeps -a
        dh_gencontrol -a
+       dh_shlibdeps -a
        dh_md5sums -a
        dh_builddeb -a
+endif
 
 binary: binary-indep binary-arch