r10662: new upstream: 4.4.0. Changes to support X.org
[ctsim.git] / debian / rules
index acf7720881d1fca1930b59441e1a6aacea02355a..21d0499f8c9a4043efc41fdb995065bda97a0076 100755 (executable)
@@ -1,7 +1,5 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -g
 endif
@@ -13,9 +11,7 @@ host_arch     := $(shell dpkg-architecture -qDEB_HOST_ARCH)
 
 pkg            := ctsim
 pkg-p4         := ctsim-pentium4
-pkg-p          := ctsim-pentium
 pkg-athlon     := ctsim-athlon
-pkg-athlon-mp  := ctsim-athlon-mp
 pkg-help       := ctsim-help
 pkg-doc                := ctsim-doc
 
@@ -23,27 +19,24 @@ ctsim-shared        := usr/share/ctsim
 
 prefix         := debian/$(pkg)
 prefix-p4      := debian/$(pkg-p4)
-prefix-p       := debian/$(pkg-p)
 prefix-athlon  := debian/$(pkg-athlon)
-prefix-athlon-mp:= debian/$(pkg-athlon-mp)
 prefix-help    := debian/$(pkg-help)
 prefix-doc     := debian/$(pkg-doc)
 
 DESTDIR                := `pwd`/$(prefix)
 DESTDIR-P4     := `pwd`/$(prefix-p4)
-DESTDIR-P      := `pwd`/$(prefix-p)
 DESTDIR-ATHLON := `pwd`/$(prefix-athlon)
-DESTDIR-ATHLON-MP      := `pwd`/$(prefix-athlon-mp)
 HELPDIR                := `pwd`/$(prefix-help)/$(ctsim-shared)
 doc-dir                := usr/share/doc/$(pkg-doc)
-pixmap-dir     := usr/X11R6/include/X11/pixmaps
+pixmap-dir     := usr/share/pixmaps
 
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
+       touch configure.in && touch aclocal.m4 && touch configure
+
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn -with-x
        touch configure-stamp
 
 
@@ -74,6 +67,9 @@ clean:
        -$(MAKE) distclean
        find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
+       # Ensure up-to-date versions of config.sub and config.guess
+       -test -r /usr/share/misc/config.sub && cp -f /usr/share/misc/config.sub config.sub
+       -test -r /usr/share/misc/config.guess && cp -f /usr/share/misc/config.guess config.guess
        dh_clean
 
 install: DH_OPTIONS=
@@ -89,11 +85,6 @@ install: build
        echo Host architecture is $(host_arch)
 ifneq (,$(findstring i386,$(host_arch)))
        # Building CPU-specific i386 flavors
-       # Pentium 
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-P)/usr --mandir=$(DESTDIR-P)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium
-       $(MAKE) all
-       ${MAKE} install
        # Pentium 4
        ${MAKE} clean
        ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
@@ -104,19 +95,10 @@ ifneq (,$(findstring i386,$(host_arch)))
        ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
        $(MAKE) all
        ${MAKE} install
-       # Athlon MP
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-ATHLON-MP)/usr --mandir=$(DESTDIR-ATHLON-MP)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon-mp
-       $(MAKE) all
-       ${MAKE} install
-       dh_installdirs -p $(pkg-p) $(pixmap-dir)
        dh_installdirs -p $(pkg-p4) $(pixmap-dir)
        dh_installdirs -p $(pkg-athlon) $(pixmap-dir)
-       dh_installdirs -p $(pkg-athlon-mp) $(pixmap-dir)
-       dh_install -p $(pkg-p) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-p4) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-athlon) debian/ctsim.xpm $(pixmap-dir)
-       dh_install -p $(pkg-athlon-mp) debian/ctsim.xpm $(pixmap-dir)
 endif
        # Add here commands to install the package into debian/ctsim.
        dh_installdirs -p $(pkg) $(pixmap-dir)
@@ -163,34 +145,46 @@ binary-arch: build install
        dh_testroot -a
 #      dh_installdebconf -a
        dh_installdocs -a
-       dh_installexamples -a tools/sample-ctsim.sh helical/sample-helical.sh
-       dh_installmenu -a
+       dh_installexamples -p $(pkg) tools/sample-ctsim.sh helical/sample-helical.sh
+ifneq (,$(findstring i386,$(host_arch)))
+       dh_installexamples -p $(pkg-p4) tools/sample-ctsim.sh helical/sample-helical.sh
+       dh_installexamples -p $(pkg-athlon) tools/sample-ctsim.sh helical/sample-helical.sh
+endif
 #      dh_installlogrotate -a
 #      dh_installemacsen -a
 #      dh_installpam -a
 #      dh_installmime -a
 #      dh_installinit -a
-       dh_installcron -a
+#      dh_installcron -a
 #      dh_installman -a
-       dh_installinfo -a
+#      dh_installinfo -a
 #      dh_undocumented -a
+#      dh_makeshlibs -a
+#      dh_perl -a
+ifeq (,$(findstring i386,$(host_arch)))
+       dh_installchangelogs -p $(pkg)ChangeLog 
+       dh_strip -p $(pkg)
+       dh_link -p $(pkg)
+       dh_compress -p $(pkg)
+       dh_fixperms -p $(pkg)
+       dh_installmenu -p $(pkg)
+       dh_installdeb -p $(pkg)
+       dh_gencontrol -p $(pkg)
+       dh_shlibdeps -p $(pkg)
+       dh_md5sums -p $(pkg)
+       dh_builddeb -p $(pkg)
+else
        dh_installchangelogs ChangeLog -a
        dh_strip -a
        dh_link -a
        dh_compress -a
        dh_fixperms -a
-#      dh_makeshlibs -a
+       dh_installmenu -a
        dh_installdeb -a
-#      dh_perl -a
-       dh_shlibdeps -a
        dh_gencontrol -a
+       dh_shlibdeps -a
        dh_md5sums -a
-       dh_builddeb -p $(pkg)
-ifneq (,$(findstring i386,$(host_arch)))
-       dh_builddeb -p $(pkg-p)
-       dh_builddeb -p $(pkg-p4)
-       dh_builddeb -p $(pkg-athlon)
-       dh_builddeb -p $(pkg-athlon-mp)
+       dh_builddeb -a
 endif
 
 binary: binary-indep binary-arch