r2082: *** empty log message ***
[ctsim.git] / debian / rules
index 394bfe22be7ff0f88f3e267f99377090ce64a9de..3c492176908b4e61fc96cff1409aefbb346394a7 100755 (executable)
@@ -11,14 +11,17 @@ export DH_COMPAT=3
 pkg            := ctsim
 pkg-help       := ctsim-help
 pkg-doc                := ctsim-doc
+pkg-doc-pdf    := ctsim-doc-pdf
 
 prefix         := debian/$(pkg)
 prefix-help    := debian/$(pkg-help)
 prefix-doc     := debian/$(pkg-doc)
+prefix-doc-pdf := debian/$(pkg-doc-pdf)
 
 DESTDIR                := $(prefix)
 HELPDIR                := $(prefix-help)/usr/share/ctsim
-DOCDIR         := $(prefix-doc)/usr/share/doc/$(pkg-doc)
+DOCDIR         := $(prefix-doc)/usr/share/doc/ctsim-doc
+PDFDIR         := $(prefix-doc-pdf)/usr/share/doc/ctsim-doc
 
 INSTALL                := install
 INSTALLFLAGS   := -g root -o root -m 0644
@@ -58,10 +61,12 @@ install: build
        # Below command also installs helpfile
        ${MAKE} install
        $(INSTALL) $(INSTALLFLAGS) debian/ctsim.xpm $(prefix)/usr/X11R6/include/X11/pixmaps
+
        $(INSTALL) $(INSTALLFLAGS) $(shell echo docs/html/*) $(DOCDIR)/html
        ln -sf $(pkg)_contents.html $(DOCDIR)/html/index.html
-       $(INSTALL) $(INSTALLFLAGS) docs/ctsim.pdf $(DOCDIR)
-       GZIP=-9 gzip $(DOCDIR)/ctsim.pdf
+
+       $(INSTALL) $(INSTALLFLAGS) docs/ctsim.pdf $(PDFDIR)
+       GZIP=-9 gzip $(PDFDIR)/ctsim.pdf
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -72,7 +77,7 @@ binary-arch: build install
        dh_testdir
        dh_testroot
 #      dh_installdebconf       
-       dh_installdocs docs/html
+       dh_installdocs -A docs/html
        dh_installexamples tools/sample-ctsim.sh helical/sample-helical.sh
        dh_installmenu
 #      dh_installlogrotate