r1846: debian updates
[ctsim.git] / debian / rules
index 79fd21213eebdf823fc775b0581c8d152b54ecbb..406ea396f0120f3bfc43fcfa451bbd4266dc6c5b 100755 (executable)
@@ -10,22 +10,17 @@ export DH_COMPAT=3
 
 pkg    := ctsim
 prefix := debian/$(pkg)
+DESTDIR := `pwd`/$(prefix)
 
 INSTALL        := install
 INSTALLFLAGS   := -g root -o root -m 0644
 INSTALLDIRFLAGS        := -d -g root -o root -m 0755
 
-SOURCEDIR      := $(prefix)/usr/share/common-lisp/source
-REPOSITORYDIR  := $(prefix)/usr/share/common-lisp/repositories/uffi
-SYSDIR         := $(prefix)/usr/share/common-lisp/systems
-DOCDIR         := $(prefix)/usr/share/doc/cl-uffi
-
-
 configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man
        touch configure-stamp
 
 
@@ -35,7 +30,7 @@ build-stamp: configure-stamp
        dh_testdir
 
        # Add here commands to compile the package.
-       $(MAKE) doc
+       $(MAKE) 
        #/usr/bin/docbook-to-man debian/uffi.sgml > uffi.1
 
        touch build-stamp
@@ -46,8 +41,9 @@ clean:
        rm -f build-stamp configure-stamp
 
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-       rm -f debian/cl-uffi.postinst.* debian/cl-uffi.prerm.*
+       -$(MAKE) distclean
+       find . -type f -and -name *~ -or -name .*~ -exec rm -f {} \;
+       rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
 
        dh_clean
 
@@ -58,6 +54,8 @@ install: build
        dh_installdirs
 
        # Add here commands to install the package into debian/ctsim.
+       # install ${INSTALLDIRFLAGS} 
+       ${MAKE} install
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -70,7 +68,7 @@ binary-arch: build install
        dh_testroot
 #      dh_installdebconf       
        dh_installdocs
-       dh_installexamples examples/*.cl
+       dh_installexamples tools/sample-ctsim.sh helical/sample-helical.sh
 #      dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen