r1846: debian updates
[ctsim.git] / debian / rules
index bc74840a4fb5cee74ab80d9c16f17d6c148c71eb..406ea396f0120f3bfc43fcfa451bbd4266dc6c5b 100755 (executable)
@@ -10,6 +10,7 @@ export DH_COMPAT=3
 
 pkg    := ctsim
 prefix := debian/$(pkg)
+DESTDIR := `pwd`/$(prefix)
 
 INSTALL        := install
 INSTALLFLAGS   := -g root -o root -m 0644
@@ -19,7 +20,7 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-       ./configure --prefix=${prefix}/usr
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man
        touch configure-stamp
 
 
@@ -41,6 +42,7 @@ clean:
 
        # Add here commands to clean up after the build process.
        -$(MAKE) distclean
+       find . -type f -and -name *~ -or -name .*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
 
        dh_clean
@@ -52,6 +54,7 @@ install: build
        dh_installdirs
 
        # Add here commands to install the package into debian/ctsim.
+       # install ${INSTALLDIRFLAGS} 
        ${MAKE} install
 
 # Build architecture-independent files here.
@@ -65,7 +68,7 @@ binary-arch: build install
        dh_testroot
 #      dh_installdebconf       
        dh_installdocs
-#      dh_installexamples examples/*.cl
+       dh_installexamples tools/sample-ctsim.sh helical/sample-helical.sh
 #      dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen
@@ -73,7 +76,7 @@ binary-arch: build install
 #      dh_installmime
 #      dh_installinit
 #      dh_installcron
-       dh_installman
+#      dh_installman
 #      dh_installinfo
 #      dh_undocumented
        dh_installchangelogs ChangeLog