r3921: *** empty log message ***
[ctsim.git] / debian / rules
index 0e73ff49be37fcb93707146205ef81cc8004ea7b..478e8110f2c0fda13f41677f7b9a7d5407620fa6 100755 (executable)
@@ -9,10 +9,11 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
        INSTALL_PROGRAM += -s
 endif
 
-host_arch      := $(dpkg-architecture -qDEB_HOST_ARCH)
+host_arch      := $(shell dpkg-architecture -qDEB_HOST_ARCH)
 
 pkg            := ctsim
 pkg-p4         := ctsim-pentium4
+pkg-p3         := ctsim-pentium3
 pkg-athlon     := ctsim-athlon
 pkg-help       := ctsim-help
 pkg-doc                := ctsim-doc
@@ -21,12 +22,14 @@ ctsim-shared        := usr/share/ctsim
 
 prefix         := debian/$(pkg)
 prefix-p4      := debian/$(pkg-p4)
+prefix-p3      := debian/$(pkg-p3)
 prefix-athlon  := debian/$(pkg-athlon)
 prefix-help    := debian/$(pkg-help)
 prefix-doc     := debian/$(pkg-doc)
 
 DESTDIR                := `pwd`/$(prefix)
 DESTDIR-P4     := `pwd`/$(prefix-p4)
+DESTDIR-P3     := `pwd`/$(prefix-p3)
 DESTDIR-ATHLON := `pwd`/$(prefix-athlon)
 HELPDIR                := `pwd`/$(prefix-help)/$(ctsim-shared)
 doc-dir                := usr/share/doc/$(pkg-doc)
@@ -79,9 +82,15 @@ install: build
        #
        dh_installdirs -p $(pkg-help) $(ctsim-shared)
        ${MAKE} install
-       #
-ifneq (,$(findstring i386,$(host_Arch)))
-       echo Building CPU-specific i386 flavors
+       # Testing for i386 optimized builds
+       echo Host architecture is $(host_arch)
+ifneq (,$(findstring i386,$(host_arch)))
+       # Building CPU-specific i386 flavors
+       # Pentium 3
+       ${MAKE} clean
+       ./configure --prefix=$(DESTDIR-P3)/usr --mandir=$(DESTDIR-P3)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium3
+       $(MAKE) all
+       ${MAKE} install
        # Pentium 4
        ${MAKE} clean
        ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
@@ -92,8 +101,10 @@ ifneq (,$(findstring i386,$(host_Arch)))
        ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
        $(MAKE) all
        ${MAKE} install
+       dh_installdirs -p $(pkg-p3) $(pixmap-dir)
        dh_installdirs -p $(pkg-p4) $(pixmap-dir)
        dh_installdirs -p $(pkg-athlon) $(pixmap-dir)
+       dh_install -p $(pkg-p3) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-p4) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-athlon) debian/ctsim.xpm $(pixmap-dir)
 endif
@@ -142,29 +153,48 @@ binary-arch: build install
        dh_testroot -a
 #      dh_installdebconf -a
        dh_installdocs -a
-       dh_installexamples -a tools/sample-ctsim.sh helical/sample-helical.sh
-       dh_installmenu -a
+       dh_installexamples -p $(pkg) tools/sample-ctsim.sh helical/sample-helical.sh
+ifneq (,$(findstring i386,$(host_arch)))
+       dh_installexamples -p $(pkg-p3) tools/sample-ctsim.sh helical/sample-helical.sh
+       dh_installexamples -p $(pkg-p4) tools/sample-ctsim.sh helical/sample-helical.sh
+       dh_installexamples -p $(pkg-athlon) tools/sample-ctsim.sh helical/sample-helical.sh
+endif
 #      dh_installlogrotate -a
 #      dh_installemacsen -a
 #      dh_installpam -a
 #      dh_installmime -a
 #      dh_installinit -a
-       dh_installcron -a
+#      dh_installcron -a
 #      dh_installman -a
-       dh_installinfo -a
+#      dh_installinfo -a
 #      dh_undocumented -a
+#      dh_makeshlibs -a
+#      dh_perl -a
+ifeq (,$(findstring i386,$(host_arch)))
+       dh_installchangelogs -p $(pkg)ChangeLog 
+       dh_strip -p $(pkg)
+       dh_link -p $(pkg)
+       dh_compress -p $(pkg)
+       dh_fixperms -p $(pkg)
+       dh_installmenu -p $(pkg)
+       dh_installdeb -p $(pkg)
+       dh_gencontrol -p $(pkg)
+       dh_shlibdeps -p $(pkg)
+       dh_md5sums -p $(pkg)
+       dh_builddeb -p $(pkg)
+else
        dh_installchangelogs ChangeLog -a
        dh_strip -a
        dh_link -a
        dh_compress -a
        dh_fixperms -a
-#      dh_makeshlibs -a
+       dh_installmenu -a
        dh_installdeb -a
-#      dh_perl -a
-       dh_shlibdeps -a
        dh_gencontrol -a
+       dh_shlibdeps -a
        dh_md5sums -a
        dh_builddeb -a
+endif
 
 binary: binary-indep binary-arch