r10521: new deb pkg
[ctsim.git] / debian / rules
index 6627b158275cfa673c6d15341357d81158e3bc24..62a6be332fcde9d868f7da665ceaf54545e6832c 100755 (executable)
@@ -34,7 +34,8 @@ pixmap-dir    := usr/share/pixmaps
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
+       touch configure.in && touch aclocal.m4 && touch configure
+
        ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
        touch configure-stamp
 
@@ -66,6 +67,9 @@ clean:
        -$(MAKE) distclean
        find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
+       # Ensure up-to-date versions of config.sub and config.guess
+       -test -r /usr/share/misc/config.sub && cp -f /usr/share/misc/config.sub config.sub
+       -test -r /usr/share/misc/config.guess && cp -f /usr/share/misc/config.guess config.guess
        dh_clean
 
 install: DH_OPTIONS=