lintian warning fixes
[ctsim.git] / debian / rules
index 1aa20200bd83d88fe36a939fede7211c6ea40e07..6388bc8f95e0039e265701b96a1672fb698a0867 100755 (executable)
@@ -1,7 +1,5 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
-
 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -g
 endif
@@ -9,34 +7,30 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
        INSTALL_PROGRAM += -s
 endif
 
-host_arch      := $(dpkg-architecture -qDEB_HOST_ARCH)
+host_arch      := $(shell dpkg-architecture -qDEB_HOST_ARCH)
 
 pkg            := ctsim
-pkg-p4         := ctsim-pentium4
-pkg-athlon     := ctsim-athlon
 pkg-help       := ctsim-help
 pkg-doc                := ctsim-doc
 
 ctsim-shared   := usr/share/ctsim
 
 prefix         := debian/$(pkg)
-prefix-p4      := debian/$(pkg-p4)
-prefix-athlon  := debian/$(pkg-athlon)
 prefix-help    := debian/$(pkg-help)
 prefix-doc     := debian/$(pkg-doc)
 
 DESTDIR                := `pwd`/$(prefix)
-DESTDIR-P4     := `pwd`/$(prefix-p4)
-DESTDIR-ATHLON := `pwd`/$(prefix-athlon)
 HELPDIR                := `pwd`/$(prefix-help)/$(ctsim-shared)
 doc-dir                := usr/share/doc/$(pkg-doc)
-pixmap-dir     := usr/X11R6/include/X11/pixmaps
-
+pixmap-dir     := usr/share/pixmaps
+desktop-dir    := usr/share/applications
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
+       autoreconf
+       touch configure.in && touch aclocal.m4 && touch configure
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn -with-x --without-lam
        touch configure-stamp
 
 
@@ -44,6 +38,7 @@ build-arch: configure-stamp build-arch-stamp
 build-arch-stamp:
        dh_testdir
        # Add here commands to compile the package.
+       $(MAKE) all
        touch build-arch-stamp
 
 build-indep: configure-stamp  build-indep-stamp
@@ -62,42 +57,29 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-arch-stamp build-indep-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       -$(MAKE) distclean
+       if [ -f Makefile -a -f config.status ]; then $(MAKE) clean; fi
        find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
+       # Ensure up-to-date versions of config.sub and config.guess
+       -test -r /usr/share/misc/config.sub && cp -f /usr/share/misc/config.sub config.sub
+       -test -r /usr/share/misc/config.guess && cp -f /usr/share/misc/config.guess config.guess
+       -rm -f configure-stamp build-indep-stamp build-arch-stamp
+       -test -r Makefile && $(MAKE) clean
        dh_clean
 
 install: DH_OPTIONS=
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
        #
        dh_installdirs -p $(pkg-help) $(ctsim-shared)
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
-       $(MAKE) all
-       ${MAKE} install
-ifeq ($(host_arch),i386)
-       # Pentium 4
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
-       $(MAKE) all
        ${MAKE} install
-       # Athlon
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
-       $(MAKE) all
-       ${MAKE} install
-endif
-       # Add here commands to install the package into debian/ctsim.
        dh_installdirs -p $(pkg) $(pixmap-dir)
-       dh_installdirs -p $(pkg-p4) $(pixmap-dir)
-       dh_installdirs -p $(pkg-athlon) $(pixmap-dir)
+       dh_installdirs -p $(pkg) $(desktop-dir)
        dh_install -p $(pkg) debian/ctsim.xpm $(pixmap-dir)
-       dh_install -p $(pkg-p4) debian/ctsim.xpm $(pixmap-dir)
-       dh_install -p $(pkg-athlon) debian/ctsim.xpm $(pixmap-dir)
+       dh_install -p $(pkg) debian/ctsim.desktop $(desktop-dir)
        dh_install -p $(pkg-help) docs/ctsim.htb $(ctsim-shared)
        dh_install -p $(pkg-doc) docs/html $(doc-dir)
        dh_link -p $(pkg-doc) $(doc-dir)/html/$(pkg)_contents.html $(doc-dir)/html/index.html
@@ -106,30 +88,20 @@ endif
        gunzip docs/ctsim.pdf.gz
        chmod +x helical/*.sh tools/*.sh
 
-# Build architecture-independent files here.
 # Pass -i to all debhelper commands in this target to reduce clutter.
 binary-indep: build install
        dh_testdir -i
        dh_testroot -i
-#      dh_installdebconf -i
        dh_installdocs -i
        dh_installexamples -i
        dh_installmenu -i
-#      dh_installlogrotate -i
-#      dh_installemacsen -i
-#      dh_installpam -i
-#      dh_installmime -i
-#      dh_installinit -i
        dh_installcron -i
-#      dh_installman -i
        dh_installinfo -i
-#      dh_undocumented -i
        dh_installchangelogs ChangeLog -i
        dh_link -i
        dh_compress -i
        dh_fixperms -i
        dh_installdeb -i
-#      dh_perl -i
        dh_gencontrol -i
        dh_md5sums -i
        dh_builddeb -i
@@ -138,27 +110,15 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir -a
        dh_testroot -a
-#      dh_installdebconf -a
        dh_installdocs -a
-       dh_installexamples -a tools/sample-ctsim.sh helical/sample-helical.sh
-       dh_installmenu -a
-#      dh_installlogrotate -a
-#      dh_installemacsen -a
-#      dh_installpam -a
-#      dh_installmime -a
-#      dh_installinit -a
-       dh_installcron -a
-#      dh_installman -a
-       dh_installinfo -a
-#      dh_undocumented -a
+       dh_installexamples -p $(pkg) tools/sample-ctsim.sh helical/sample-helical.sh
        dh_installchangelogs ChangeLog -a
        dh_strip -a
        dh_link -a
        dh_compress -a
        dh_fixperms -a
-#      dh_makeshlibs -a
+       dh_installmenu -a
        dh_installdeb -a
-#      dh_perl -a
        dh_shlibdeps -a
        dh_gencontrol -a
        dh_md5sums -a
@@ -167,4 +127,3 @@ binary-arch: build install
 binary: binary-indep binary-arch
 
 .PHONY: build clean binary-indep binary-arch binary install configure
-