lintian warning fixes
[ctsim.git] / debian / rules
index 798df69810e23293c9bf2d84620a432ccc9a8b78..6388bc8f95e0039e265701b96a1672fb698a0867 100755 (executable)
@@ -10,19 +10,16 @@ endif
 host_arch      := $(shell dpkg-architecture -qDEB_HOST_ARCH)
 
 pkg            := ctsim
-pkg-p4         := ctsim-pentium4
 pkg-help       := ctsim-help
 pkg-doc                := ctsim-doc
 
 ctsim-shared   := usr/share/ctsim
 
 prefix         := debian/$(pkg)
-prefix-p4      := debian/$(pkg-p4)
 prefix-help    := debian/$(pkg-help)
 prefix-doc     := debian/$(pkg-doc)
 
 DESTDIR                := `pwd`/$(prefix)
-DESTDIR-P4     := `pwd`/$(prefix-p4)
 HELPDIR                := `pwd`/$(prefix-help)/$(ctsim-shared)
 doc-dir                := usr/share/doc/$(pkg-doc)
 pixmap-dir     := usr/share/pixmaps
@@ -31,9 +28,9 @@ desktop-dir   := usr/share/applications
 configure: configure-stamp
 configure-stamp:
        dh_testdir
+       autoreconf
        touch configure.in && touch aclocal.m4 && touch configure
-
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn -with-x
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn -with-x --without-lam
        touch configure-stamp
 
 
@@ -60,41 +57,25 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-arch-stamp build-indep-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       -$(MAKE) distclean
+       if [ -f Makefile -a -f config.status ]; then $(MAKE) clean; fi
        find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
        # Ensure up-to-date versions of config.sub and config.guess
        -test -r /usr/share/misc/config.sub && cp -f /usr/share/misc/config.sub config.sub
        -test -r /usr/share/misc/config.guess && cp -f /usr/share/misc/config.guess config.guess
+       -rm -f configure-stamp build-indep-stamp build-arch-stamp
+       -test -r Makefile && $(MAKE) clean
        dh_clean
 
 install: DH_OPTIONS=
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
        #
        dh_installdirs -p $(pkg-help) $(ctsim-shared)
        ${MAKE} install
-       # Testing for i386 optimized builds
-       echo Host architecture is $(host_arch)
-ifneq (,$(findstring i386,$(host_arch)))
-       # Building CPU-specific i386 flavors
-       # Pentium 4
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
-       $(MAKE) all
-       ${MAKE} install
-
-       dh_installdirs -p $(pkg-p4) $(pixmap-dir)
-       dh_installdirs -p $(pkg-p4) $(desktop-dir)
-       dh_install -p $(pkg-p4) debian/ctsim.xpm $(pixmap-dir)
-       dh_install -p $(pkg-p4) debian/ctsim.desktop $(desktop-dir)
-
-endif
-       # Add here commands to install the package into debian/ctsim.
        dh_installdirs -p $(pkg) $(pixmap-dir)
        dh_installdirs -p $(pkg) $(desktop-dir)
        dh_install -p $(pkg) debian/ctsim.xpm $(pixmap-dir)
@@ -131,23 +112,6 @@ binary-arch: build install
        dh_testroot -a
        dh_installdocs -a
        dh_installexamples -p $(pkg) tools/sample-ctsim.sh helical/sample-helical.sh
-ifneq (,$(findstring i386,$(host_arch)))
-       dh_installexamples -p $(pkg-p4) tools/sample-ctsim.sh helical/sample-helical.sh
-endif
-
-ifeq (,$(findstring i386,$(host_arch)))
-       dh_installchangelogs -p $(pkg) ChangeLog 
-       dh_strip -p $(pkg)
-       dh_link -p $(pkg)
-       dh_compress -p $(pkg)
-       dh_fixperms -p $(pkg)
-       dh_installmenu -p $(pkg)
-       dh_installdeb -p $(pkg)
-       dh_gencontrol -p $(pkg)
-       dh_shlibdeps -p $(pkg)
-       dh_md5sums -p $(pkg)
-       dh_builddeb -p $(pkg)
-else
        dh_installchangelogs ChangeLog -a
        dh_strip -a
        dh_link -a
@@ -155,11 +119,10 @@ else
        dh_fixperms -a
        dh_installmenu -a
        dh_installdeb -a
-       dh_gencontrol -a
        dh_shlibdeps -a
+       dh_gencontrol -a
        dh_md5sums -a
        dh_builddeb -a
-endif
 
 binary: binary-indep binary-arch