r2083: *** empty log message ***
[ctsim.git] / debian / rules
index 79fd21213eebdf823fc775b0581c8d152b54ecbb..63f132ee0173658b05076036963993b151f2dc9b 100755 (executable)
@@ -3,29 +3,35 @@
 # GNU copyright 1997 to 1999 by Joey Hess.
 
 # Uncomment this to turn on verbose mode.
-export DH_VERBOSE=1
+export DH_VERBOSE=0
 
 # This is the debhelper compatibility version to use.
 export DH_COMPAT=3
 
-pkg    := ctsim
-prefix := debian/$(pkg)
+pkg            := ctsim
+pkg-help       := ctsim-help
+pkg-doc                := ctsim-doc
+pkg-doc-pdf    := ctsim-doc-pdf
 
-INSTALL        := install
-INSTALLFLAGS   := -g root -o root -m 0644
-INSTALLDIRFLAGS        := -d -g root -o root -m 0755
+prefix         := debian/$(pkg)
+prefix-help    := debian/$(pkg-help)
+prefix-doc     := debian/$(pkg-doc)
+prefix-doc-pdf := debian/$(pkg-doc-pdf)
 
-SOURCEDIR      := $(prefix)/usr/share/common-lisp/source
-REPOSITORYDIR  := $(prefix)/usr/share/common-lisp/repositories/uffi
-SYSDIR         := $(prefix)/usr/share/common-lisp/systems
-DOCDIR         := $(prefix)/usr/share/doc/cl-uffi
+DESTDIR                := `pwd`/$(prefix)
+HELPDIR                := `pwd`/$(prefix-help)
+DOCDIR         := $(prefix-doc)/usr/share/doc/ctsim-doc
+PDFDIR         := $(prefix-doc-pdf)/usr/share/doc/ctsim-doc
 
+INSTALL                := install
+INSTALLFLAGS   := -g root -o root -m 0644
+INSTALLDIRFLAGS        := -d -g root -o root -m 0755
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR)
        touch configure-stamp
 
 
@@ -33,22 +39,18 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-
        # Add here commands to compile the package.
-       $(MAKE) doc
-       #/usr/bin/docbook-to-man debian/uffi.sgml > uffi.1
-
+       $(MAKE) all
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-       rm -f debian/cl-uffi.postinst.* debian/cl-uffi.prerm.*
-
+       -$(MAKE) distclean
+       find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
+       rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
        dh_clean
 
 install: build
@@ -56,22 +58,28 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
+       # Below command also installs helpfile
+       ${MAKE} install
+       $(INSTALL) $(INSTALLFLAGS) debian/ctsim.xpm $(prefix)/usr/X11R6/include/X11/pixmaps
 
-       # Add here commands to install the package into debian/ctsim.
+       $(INSTALL) $(INSTALLFLAGS) $(shell echo docs/html/*) $(DOCDIR)/html
+       ln -sf $(pkg)_contents.html $(DOCDIR)/html/index.html
+
+       $(INSTALL) $(INSTALLFLAGS) docs/ctsim.pdf $(PDFDIR)
+       GZIP=-9 gzip $(PDFDIR)/ctsim.pdf
 
 # Build architecture-independent files here.
 binary-indep: build install
 
 
-
 # Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir
        dh_testroot
 #      dh_installdebconf       
-       dh_installdocs
-       dh_installexamples examples/*.cl
-#      dh_installmenu
+       dh_installdocs -A docs/html
+       dh_installexamples tools/sample-ctsim.sh helical/sample-helical.sh
+       dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen
 #      dh_installpam
@@ -82,7 +90,7 @@ binary-arch: build install
 #      dh_installinfo
 #      dh_undocumented
        dh_installchangelogs ChangeLog
-       dh_link
+#      dh_link
        dh_strip
        dh_compress
        dh_fixperms