Update debian configure options
[ctsim.git] / debian / rules
index e076c2a37eb46392b2e8c4fa8e89c6b92d2e482d..7a13e1ce044f034712495d9c08eac520f7384a2a 100755 (executable)
@@ -1,95 +1,20 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
 
-# Uncomment this to turn on verbose mode.
-export DH_VERBOSE=1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=3
+%:
+       dh $@  --with autoreconf
 
-pkg    := ctsim
-prefix := debian/$(pkg)
-DESTDIR := `pwd`/$(prefix)
-SHAREDOCDIR := $(DESTDIR)/usr/share/$(pkg)
+override_dh_auto_clean:
+       dh_auto_clean
+       rm -f helical/sample-helical.sh tools/sample-ctsim.sh
 
-INSTALL        := install
-INSTALLFLAGS   := -g root -o root -m 0644
-INSTALLDIRFLAGS        := -d -g root -o root -m 0755
+override_dh_auto_configure:
+       dh_auto_configure -- --with-ctn -with-x --without-lam
 
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man
-       touch configure-stamp
+override_dh_installdocs-indep:
+       (cd docs; tar xzf html.tar.gz)
+       dh_installdocs -i
 
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-       # Add here commands to compile the package.
-       $(MAKE) 
-       (cd doc; $(MAKE) htmlhelp)
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-       # Add here commands to clean up after the build process.
-       -$(MAKE) distclean
-       find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
-       rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       # Add here commands to install the package into debian/ctsim.
-       # install ${INSTALLDIRFLAGS} 
-       ${MAKE} install
-       $(INSTALL) $(INSTALLFLAGS) $(shell echo src/*.htb) $(SHAREDOCDIR)
-
-# Build architecture-independent files here.
-binary-indep: build install
-
-
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-#      dh_installdebconf       
-       dh_installdocs doc/html
-       dh_installexamples tools/sample-ctsim.sh helical/sample-helical.sh
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installman
-#      dh_installinfo
-#      dh_undocumented
+override_dh_installchangelogs:
        dh_installchangelogs ChangeLog
-#      dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_perl
-#      dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
-