r9686: remove old p3 package
[ctsim.git] / debian / rules
index 260bf645b0187a5b52087119656fd8aa9bc2098c..7bfcfea8f151a08280d7e0d83ca4bbbd7062822d 100755 (executable)
@@ -1,19 +1,35 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=4
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -g
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+       INSTALL_PROGRAM += -s
+endif
+
+host_arch      := $(shell dpkg-architecture -qDEB_HOST_ARCH)
 
 pkg            := ctsim
+pkg-p4         := ctsim-pentium4
+pkg-athlon     := ctsim-athlon
 pkg-help       := ctsim-help
 pkg-doc                := ctsim-doc
 
+ctsim-shared   := usr/share/ctsim
+
 prefix         := debian/$(pkg)
+prefix-p4      := debian/$(pkg-p4)
+prefix-athlon  := debian/$(pkg-athlon)
 prefix-help    := debian/$(pkg-help)
 prefix-doc     := debian/$(pkg-doc)
 
 DESTDIR                := `pwd`/$(prefix)
-HELPDIR                := `pwd`/$(prefix-help)/usr/share/ctsim
+DESTDIR-P4     := `pwd`/$(prefix-p4)
+DESTDIR-ATHLON := `pwd`/$(prefix-athlon)
+HELPDIR                := `pwd`/$(prefix-help)/$(ctsim-shared)
 doc-dir                := usr/share/doc/$(pkg-doc)
-pixmap-dir     := usr/X11R6/include/X11/pixmaps
+pixmap-dir     := usr/share/pixmaps
+
 
 configure: configure-stamp
 configure-stamp:
@@ -58,15 +74,40 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
-       # Add here commands to install the package into debian/uffi.
+       #
+       dh_installdirs -p $(pkg-help) $(ctsim-shared)
+       ${MAKE} install
+       # Testing for i386 optimized builds
+       echo Host architecture is $(host_arch)
+ifneq (,$(findstring i386,$(host_arch)))
+       # Building CPU-specific i386 flavors
+       # Pentium 4
+       ${MAKE} clean
+       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
+       $(MAKE) all
+       ${MAKE} install
+       # Athlon
+       ${MAKE} clean
+       ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
+       $(MAKE) all
        ${MAKE} install
+       dh_installdirs -p $(pkg-p3) $(pixmap-dir)
+       dh_installdirs -p $(pkg-p4) $(pixmap-dir)
+       dh_installdirs -p $(pkg-athlon) $(pixmap-dir)
+       dh_install -p $(pkg-p3) debian/ctsim.xpm $(pixmap-dir)
+       dh_install -p $(pkg-p4) debian/ctsim.xpm $(pixmap-dir)
+       dh_install -p $(pkg-athlon) debian/ctsim.xpm $(pixmap-dir)
+endif
+       # Add here commands to install the package into debian/ctsim.
        dh_installdirs -p $(pkg) $(pixmap-dir)
        dh_install -p $(pkg) debian/ctsim.xpm $(pixmap-dir)
+       dh_install -p $(pkg-help) docs/ctsim.htb $(ctsim-shared)
        dh_install -p $(pkg-doc) docs/html $(doc-dir)
        dh_link -p $(pkg-doc) $(doc-dir)/html/$(pkg)_contents.html $(doc-dir)/html/index.html
        gzip -9 docs/ctsim.pdf
        dh_install -p $(pkg-doc) docs/ctsim.pdf.gz $(doc-dir)
        gunzip docs/ctsim.pdf.gz
+       chmod +x helical/*.sh tools/*.sh
 
 # Build architecture-independent files here.
 # Pass -i to all debhelper commands in this target to reduce clutter.
@@ -102,29 +143,48 @@ binary-arch: build install
        dh_testroot -a
 #      dh_installdebconf -a
        dh_installdocs -a
-       dh_installexamples -a tools/sample-ctsim.sh helical/sample-helical.sh
-       dh_installmenu -a
+       dh_installexamples -p $(pkg) tools/sample-ctsim.sh helical/sample-helical.sh
+ifneq (,$(findstring i386,$(host_arch)))
+       dh_installexamples -p $(pkg-p3) tools/sample-ctsim.sh helical/sample-helical.sh
+       dh_installexamples -p $(pkg-p4) tools/sample-ctsim.sh helical/sample-helical.sh
+       dh_installexamples -p $(pkg-athlon) tools/sample-ctsim.sh helical/sample-helical.sh
+endif
 #      dh_installlogrotate -a
 #      dh_installemacsen -a
 #      dh_installpam -a
 #      dh_installmime -a
 #      dh_installinit -a
-       dh_installcron -a
+#      dh_installcron -a
 #      dh_installman -a
-       dh_installinfo -a
+#      dh_installinfo -a
 #      dh_undocumented -a
+#      dh_makeshlibs -a
+#      dh_perl -a
+ifeq (,$(findstring i386,$(host_arch)))
+       dh_installchangelogs -p $(pkg)ChangeLog 
+       dh_strip -p $(pkg)
+       dh_link -p $(pkg)
+       dh_compress -p $(pkg)
+       dh_fixperms -p $(pkg)
+       dh_installmenu -p $(pkg)
+       dh_installdeb -p $(pkg)
+       dh_gencontrol -p $(pkg)
+       dh_shlibdeps -p $(pkg)
+       dh_md5sums -p $(pkg)
+       dh_builddeb -p $(pkg)
+else
        dh_installchangelogs ChangeLog -a
        dh_strip -a
        dh_link -a
        dh_compress -a
        dh_fixperms -a
-#      dh_makeshlibs -a
+       dh_installmenu -a
        dh_installdeb -a
-#      dh_perl -a
-       dh_shlibdeps -a
        dh_gencontrol -a
+       dh_shlibdeps -a
        dh_md5sums -a
        dh_builddeb -a
+endif
 
 binary: binary-indep binary-arch