r9686: remove old p3 package
[ctsim.git] / debian / rules
index 4d073ab967808f5de8dd44cacb7d4e9f3d3f7673..7bfcfea8f151a08280d7e0d83ca4bbbd7062822d 100755 (executable)
@@ -11,7 +11,6 @@ host_arch     := $(shell dpkg-architecture -qDEB_HOST_ARCH)
 
 pkg            := ctsim
 pkg-p4         := ctsim-pentium4
-pkg-p3         := ctsim-pentium3
 pkg-athlon     := ctsim-athlon
 pkg-help       := ctsim-help
 pkg-doc                := ctsim-doc
@@ -20,18 +19,16 @@ ctsim-shared        := usr/share/ctsim
 
 prefix         := debian/$(pkg)
 prefix-p4      := debian/$(pkg-p4)
-prefix-p3      := debian/$(pkg-p3)
 prefix-athlon  := debian/$(pkg-athlon)
 prefix-help    := debian/$(pkg-help)
 prefix-doc     := debian/$(pkg-doc)
 
 DESTDIR                := `pwd`/$(prefix)
 DESTDIR-P4     := `pwd`/$(prefix-p4)
-DESTDIR-P3     := `pwd`/$(prefix-p3)
 DESTDIR-ATHLON := `pwd`/$(prefix-athlon)
 HELPDIR                := `pwd`/$(prefix-help)/$(ctsim-shared)
 doc-dir                := usr/share/doc/$(pkg-doc)
-pixmap-dir     := usr/X11R6/include/X11/pixmaps
+pixmap-dir     := usr/share/pixmaps
 
 
 configure: configure-stamp
@@ -84,11 +81,6 @@ install: build
        echo Host architecture is $(host_arch)
 ifneq (,$(findstring i386,$(host_arch)))
        # Building CPU-specific i386 flavors
-       # Pentium 3
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-P3)/usr --mandir=$(DESTDIR-P3)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium3
-       $(MAKE) all
-       ${MAKE} install
        # Pentium 4
        ${MAKE} clean
        ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4