debian/control: Change Build-Depends to libpng-dev from libpng12-dev
[ctsim.git] / debian / rules
index 411b28cc6acc3ce630475dcd3b9dbdcdb8e9bf4b..827e148cb6e5f7c82616f088b76ce561d0c03fea 100755 (executable)
@@ -28,8 +28,7 @@ desktop-dir   := usr/share/applications
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       touch configure.in && touch aclocal.m4 && touch configure
-
+       dh_autotools-dev_updateconfig
        ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn -with-x --without-lam
        touch configure-stamp
 
@@ -37,17 +36,12 @@ configure-stamp:
 build-arch: configure-stamp build-arch-stamp
 build-arch-stamp:
        dh_testdir
-       # Add here commands to compile the package.
        $(MAKE) all
        touch build-arch-stamp
 
 build-indep: configure-stamp  build-indep-stamp
 build-indep-stamp:
        dh_testdir
-       # Add here command to compile/build the arch indep package.
-       # It's ok not to do anything here, if you don't need to build
-       #  anything for this package.
-       #/usr/bin/docbook-to-man debian/#PACKAGE#.sgml > #PACKAGE#.1
        (cd docs; tar xzf html.tar.gz)
        touch build-indep-stamp
 
@@ -57,38 +51,35 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-arch-stamp build-indep-stamp configure-stamp
-       if [ -f Makefile ]; then $(MAKE) clean; fi
+       if [ -f Makefile -a -f config.status ]; then $(MAKE) clean; fi
        find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
-       # Ensure up-to-date versions of config.sub and config.guess
-       -test -r /usr/share/misc/config.sub && cp -f /usr/share/misc/config.sub config.sub
-       -test -r /usr/share/misc/config.guess && cp -f /usr/share/misc/config.guess config.guess
+       dh_autotools-dev_restoreconfig
        -rm -f configure-stamp build-indep-stamp build-arch-stamp
-       -test -r Makefile && $(MAKE) clean
        dh_clean
 
 install: DH_OPTIONS=
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
-       #
        dh_installdirs -p $(pkg-help) $(ctsim-shared)
        ${MAKE} install
+       rm $(DESTDIR)/usr/share/doc/$(pkg)/simulate.html
        dh_installdirs -p $(pkg) $(pixmap-dir)
        dh_installdirs -p $(pkg) $(desktop-dir)
        dh_install -p $(pkg) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg) debian/ctsim.desktop $(desktop-dir)
        dh_install -p $(pkg-help) docs/ctsim.htb $(ctsim-shared)
        dh_install -p $(pkg-doc) docs/html $(doc-dir)
+       dh_install -p $(pkg-doc) html/simulate.html $(doc-dir)/examples
        dh_link -p $(pkg-doc) $(doc-dir)/html/$(pkg)_contents.html $(doc-dir)/html/index.html
        gzip -9 docs/ctsim.pdf
        dh_install -p $(pkg-doc) docs/ctsim.pdf.gz $(doc-dir)
        gunzip docs/ctsim.pdf.gz
        chmod +x helical/*.sh tools/*.sh
 
-# Pass -i to all debhelper commands in this target to reduce clutter.
 binary-indep: build install
        dh_testdir -i
        dh_testroot -i
@@ -98,6 +89,7 @@ binary-indep: build install
        dh_installcron -i
        dh_installinfo -i
        dh_installchangelogs ChangeLog -i
+       dh_installexamples -p $(pkg-doc) tools/sample-ctsim.sh helical/sample-helical.sh -i
        dh_link -i
        dh_compress -i
        dh_fixperms -i
@@ -106,12 +98,10 @@ binary-indep: build install
        dh_md5sums -i
        dh_builddeb -i
 
-# Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir -a
        dh_testroot -a
-       dh_installdocs -a
-       dh_installexamples -p $(pkg) tools/sample-ctsim.sh helical/sample-helical.sh
+       dh_installdocs -Xsimulate.html -a
        dh_installchangelogs ChangeLog -a
        dh_strip -a
        dh_link -a
@@ -119,8 +109,8 @@ binary-arch: build install
        dh_fixperms -a
        dh_installmenu -a
        dh_installdeb -a
-       dh_gencontrol -a
        dh_shlibdeps -a
+       dh_gencontrol -a
        dh_md5sums -a
        dh_builddeb -a