r3886: Auto commit for Debian build
[ctsim.git] / debian / rules
index 758a7d7b50ca2d5ef468bdca2332cb86a025d5bc..96f290dadaeb3ee3176270bc953917451d07a8c3 100755 (executable)
@@ -3,14 +3,20 @@
 export DH_COMPAT=4
 
 pkg            := ctsim
+pkg-p4         := ctsim-pentium4
+pkg-athlon     := ctsim-athlon
 pkg-help       := ctsim-help
 pkg-doc                := ctsim-doc
 
 prefix         := debian/$(pkg)
+prefix-p4      := debian/$(pkg-p4)
+prefix-athlon  := debian/$(pkg-athlon)
 prefix-help    := debian/$(pkg-help)
 prefix-doc     := debian/$(pkg-doc)
 
 DESTDIR                := `pwd`/$(prefix)
+DESTDIR-P4     := `pwd`/$(prefix-p4)
+DESTDIR-ATHLON := `pwd`/$(prefix-athlon)
 HELPDIR                := `pwd`/$(prefix-help)/usr/share/ctsim
 doc-dir                := usr/share/doc/$(pkg-doc)
 pixmap-dir     := usr/X11R6/include/X11/pixmaps
@@ -19,7 +25,6 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
        touch configure-stamp
 
 
@@ -27,7 +32,17 @@ build-arch: configure-stamp build-arch-stamp
 build-arch-stamp:
        dh_testdir
        # Add here commands to compile the package.
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
+       $(MAKE) all
+       ${MAKE} install
+       ${MAKE} clean
+       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --mcpu=pentium4
        $(MAKE) all
+       ${MAKE} install
+       ${MAKE} clean
+       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --mcpu=athlon
+       $(MAKE) all
+       ${MAKE} install
        touch build-arch-stamp
 
 build-indep: configure-stamp  build-indep-stamp
@@ -58,10 +73,9 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
-       # Add here commands to install the package into debian/uffi.
-       ${MAKE} install
-       dh_installdirs -p $(pkg) $(pixmap-dir)
-       dh_install -p $(pkg) debian/ctsim.xpm $(pixmap-dir)
+       # Add here commands to install the package into debian/ctsim.
+       dh_installdirs -p $(pkg-help) $(pixmap-dir)
+       dh_install -p $(pkg-help) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-doc) docs/html $(doc-dir)
        dh_link -p $(pkg-doc) $(doc-dir)/html/$(pkg)_contents.html $(doc-dir)/html/index.html
        gzip -9 docs/ctsim.pdf