r3896: Automatic commit for debian_version_4_1_0-1
[ctsim.git] / debian / rules
index ff7c2d94f6c88158ccd0a8fc4d17349722b8fc6d..9d376e8cf97b02470471898400b8c9913ae82d62 100755 (executable)
@@ -37,6 +37,7 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
        touch configure-stamp
 
 
@@ -44,22 +45,7 @@ build-arch: configure-stamp build-arch-stamp
 build-arch-stamp:
        dh_testdir
        # Add here commands to compile the package.
-       dh_installdirs -p $(pkg-help) $(ctsim-shared)
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
        $(MAKE) all
-       ${MAKE} install
-ifeq ($(host_arch),i386)
-       # Pentium 4
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
-       $(MAKE) all
-       ${MAKE} install
-       # Athlon
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
-       $(MAKE) all
-       ${MAKE} install
-endif
        touch build-arch-stamp
 
 build-indep: configure-stamp  build-indep-stamp
@@ -90,13 +76,31 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
-       # Add here commands to install the package into debian/ctsim.
-       dh_installdirs -p $(pkg) $(pixmap-dir)
+       #
+       dh_installdirs -p $(pkg-help) $(ctsim-shared)
+       ${MAKE} install
+       echo Testing for i386 optimized builds
+       echo Host architecture is $(host_arch)
+ifneq (,$(findstring i386,$(host_arch)))
+       echo Building CPU-specific i386 flavors
+       # Pentium 4
+       ${MAKE} clean
+       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
+       $(MAKE) all
+       ${MAKE} install
+       # Athlon
+       ${MAKE} clean
+       ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
+       $(MAKE) all
+       ${MAKE} install
        dh_installdirs -p $(pkg-p4) $(pixmap-dir)
        dh_installdirs -p $(pkg-athlon) $(pixmap-dir)
-       dh_install -p $(pkg) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-p4) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-athlon) debian/ctsim.xpm $(pixmap-dir)
+endif
+       # Add here commands to install the package into debian/ctsim.
+       dh_installdirs -p $(pkg) $(pixmap-dir)
+       dh_install -p $(pkg) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-help) docs/ctsim.htb $(ctsim-shared)
        dh_install -p $(pkg-doc) docs/html $(doc-dir)
        dh_link -p $(pkg-doc) $(doc-dir)/html/$(pkg)_contents.html $(doc-dir)/html/index.html