r3897: Automatic commit for debian_version_4_1_0-1
[ctsim.git] / debian / rules
index 1aa20200bd83d88fe36a939fede7211c6ea40e07..9dd19a4fa53b7f6a5d09e7137fca3a60b58baa9a 100755 (executable)
@@ -9,7 +9,7 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
        INSTALL_PROGRAM += -s
 endif
 
-host_arch      := $(dpkg-architecture -qDEB_HOST_ARCH)
+host_arch      := $(shell dpkg-architecture -qDEB_HOST_ARCH)
 
 pkg            := ctsim
 pkg-p4         := ctsim-pentium4
@@ -37,6 +37,7 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
        touch configure-stamp
 
 
@@ -44,6 +45,7 @@ build-arch: configure-stamp build-arch-stamp
 build-arch-stamp:
        dh_testdir
        # Add here commands to compile the package.
+       $(MAKE) all
        touch build-arch-stamp
 
 build-indep: configure-stamp  build-indep-stamp
@@ -76,10 +78,11 @@ install: build
        dh_installdirs
        #
        dh_installdirs -p $(pkg-help) $(ctsim-shared)
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
-       $(MAKE) all
        ${MAKE} install
-ifeq ($(host_arch),i386)
+       echo Testing for i386 optimized builds
+       echo Host architecture is $(host_arch)
+ifneq (,$(findstring i386,$(host_arch)))
+       echo Building CPU-specific i386 flavors
        # Pentium 4
        ${MAKE} clean
        ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
@@ -90,14 +93,14 @@ ifeq ($(host_arch),i386)
        ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
        $(MAKE) all
        ${MAKE} install
-endif
-       # Add here commands to install the package into debian/ctsim.
-       dh_installdirs -p $(pkg) $(pixmap-dir)
        dh_installdirs -p $(pkg-p4) $(pixmap-dir)
        dh_installdirs -p $(pkg-athlon) $(pixmap-dir)
-       dh_install -p $(pkg) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-p4) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-athlon) debian/ctsim.xpm $(pixmap-dir)
+endif
+       # Add here commands to install the package into debian/ctsim.
+       dh_installdirs -p $(pkg) $(pixmap-dir)
+       dh_install -p $(pkg) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-help) docs/ctsim.htb $(ctsim-shared)
        dh_install -p $(pkg-doc) docs/html $(doc-dir)
        dh_link -p $(pkg-doc) $(doc-dir)/html/$(pkg)_contents.html $(doc-dir)/html/index.html
@@ -162,7 +165,11 @@ binary-arch: build install
        dh_shlibdeps -a
        dh_gencontrol -a
        dh_md5sums -a
-       dh_builddeb -a
+       dh_builddeb -p $(pkg)
+ifneq (,$(findstring i386,$(host_arch)))
+       dh_builddeb -p $(pkg-p4)
+       dh_builddeb -p $(pkg-athlon)
+endif
 
 binary: binary-indep binary-arch