r1852: *** empty log message ***
[ctsim.git] / debian / rules
index b1370c9ccecc0cec561016e33c7fb0f633b4efd3..ab5ea57719bc92f55a75d5cca633cb9c65b370e3 100755 (executable)
@@ -28,23 +28,18 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-
        # Add here commands to compile the package.
        $(MAKE) 
-       #/usr/bin/docbook-to-man debian/uffi.sgml > uffi.1
-
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-
        # Add here commands to clean up after the build process.
        -$(MAKE) distclean
        find . -type f -and -name *~ -or -name .*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
-
        dh_clean
 
 install: build
@@ -56,7 +51,6 @@ install: build
        # Add here commands to install the package into debian/ctsim.
        # install ${INSTALLDIRFLAGS} 
        ${MAKE} install
-       cp -a doc/html $(DESTDIR)/usr/share/doc/${PKG}
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -68,7 +62,7 @@ binary-arch: build install
        dh_testdir
        dh_testroot
 #      dh_installdebconf       
-#      dh_installdocs
+       dh_installdocs doc/html
        dh_installexamples tools/sample-ctsim.sh helical/sample-helical.sh
 #      dh_installmenu
 #      dh_installlogrotate