r3899: Automatic commit for debian_version_4_1_0-1
[ctsim.git] / debian / rules
index 9de1b7f008c1c01fe4331bbf38aa00fe07da8e03..acf7720881d1fca1930b59441e1a6aacea02355a 100755 (executable)
@@ -2,9 +2,20 @@
 
 export DH_COMPAT=4
 
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -g
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+       INSTALL_PROGRAM += -s
+endif
+
+host_arch      := $(shell dpkg-architecture -qDEB_HOST_ARCH)
+
 pkg            := ctsim
 pkg-p4         := ctsim-pentium4
+pkg-p          := ctsim-pentium
 pkg-athlon     := ctsim-athlon
+pkg-athlon-mp  := ctsim-athlon-mp
 pkg-help       := ctsim-help
 pkg-doc                := ctsim-doc
 
@@ -12,21 +23,27 @@ ctsim-shared        := usr/share/ctsim
 
 prefix         := debian/$(pkg)
 prefix-p4      := debian/$(pkg-p4)
+prefix-p       := debian/$(pkg-p)
 prefix-athlon  := debian/$(pkg-athlon)
+prefix-athlon-mp:= debian/$(pkg-athlon-mp)
 prefix-help    := debian/$(pkg-help)
 prefix-doc     := debian/$(pkg-doc)
 
 DESTDIR                := `pwd`/$(prefix)
 DESTDIR-P4     := `pwd`/$(prefix-p4)
+DESTDIR-P      := `pwd`/$(prefix-p)
 DESTDIR-ATHLON := `pwd`/$(prefix-athlon)
+DESTDIR-ATHLON-MP      := `pwd`/$(prefix-athlon-mp)
 HELPDIR                := `pwd`/$(prefix-help)/$(ctsim-shared)
 doc-dir                := usr/share/doc/$(pkg-doc)
 pixmap-dir     := usr/X11R6/include/X11/pixmaps
 
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
        touch configure-stamp
 
 
@@ -34,18 +51,7 @@ build-arch: configure-stamp build-arch-stamp
 build-arch-stamp:
        dh_testdir
        # Add here commands to compile the package.
-       dh_installdirs -p $(pkg-help) $(ctsim-shared)
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
        $(MAKE) all
-       ${MAKE} install
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
-       $(MAKE) all
-       ${MAKE} install
-       ${MAKE} clean
-       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --mcpu=athlon
-       $(MAKE) all
-       ${MAKE} install
        touch build-arch-stamp
 
 build-indep: configure-stamp  build-indep-stamp
@@ -76,9 +82,45 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
+       #
+       dh_installdirs -p $(pkg-help) $(ctsim-shared)
+       ${MAKE} install
+       # Testing for i386 optimized builds
+       echo Host architecture is $(host_arch)
+ifneq (,$(findstring i386,$(host_arch)))
+       # Building CPU-specific i386 flavors
+       # Pentium 
+       ${MAKE} clean
+       ./configure --prefix=$(DESTDIR-P)/usr --mandir=$(DESTDIR-P)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium
+       $(MAKE) all
+       ${MAKE} install
+       # Pentium 4
+       ${MAKE} clean
+       ./configure --prefix=$(DESTDIR-P4)/usr --mandir=$(DESTDIR-P4)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=pentium4
+       $(MAKE) all
+       ${MAKE} install
+       # Athlon
+       ${MAKE} clean
+       ./configure --prefix=$(DESTDIR-ATHLON)/usr --mandir=$(DESTDIR-ATHLON)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon
+       $(MAKE) all
+       ${MAKE} install
+       # Athlon MP
+       ${MAKE} clean
+       ./configure --prefix=$(DESTDIR-ATHLON-MP)/usr --mandir=$(DESTDIR-ATHLON-MP)/usr/share/man --datadir=$(HELPDIR) --with-ctn --with-mcpu=athlon-mp
+       $(MAKE) all
+       ${MAKE} install
+       dh_installdirs -p $(pkg-p) $(pixmap-dir)
+       dh_installdirs -p $(pkg-p4) $(pixmap-dir)
+       dh_installdirs -p $(pkg-athlon) $(pixmap-dir)
+       dh_installdirs -p $(pkg-athlon-mp) $(pixmap-dir)
+       dh_install -p $(pkg-p) debian/ctsim.xpm $(pixmap-dir)
+       dh_install -p $(pkg-p4) debian/ctsim.xpm $(pixmap-dir)
+       dh_install -p $(pkg-athlon) debian/ctsim.xpm $(pixmap-dir)
+       dh_install -p $(pkg-athlon-mp) debian/ctsim.xpm $(pixmap-dir)
+endif
        # Add here commands to install the package into debian/ctsim.
-       dh_installdirs -p $(pkg-help) $(pixmap-dir)
-       dh_install -p $(pkg-help) debian/ctsim.xpm $(pixmap-dir)
+       dh_installdirs -p $(pkg) $(pixmap-dir)
+       dh_install -p $(pkg) debian/ctsim.xpm $(pixmap-dir)
        dh_install -p $(pkg-help) docs/ctsim.htb $(ctsim-shared)
        dh_install -p $(pkg-doc) docs/html $(doc-dir)
        dh_link -p $(pkg-doc) $(doc-dir)/html/$(pkg)_contents.html $(doc-dir)/html/index.html
@@ -143,7 +185,13 @@ binary-arch: build install
        dh_shlibdeps -a
        dh_gencontrol -a
        dh_md5sums -a
-       dh_builddeb -a
+       dh_builddeb -p $(pkg)
+ifneq (,$(findstring i386,$(host_arch)))
+       dh_builddeb -p $(pkg-p)
+       dh_builddeb -p $(pkg-p4)
+       dh_builddeb -p $(pkg-athlon)
+       dh_builddeb -p $(pkg-athlon-mp)
+endif
 
 binary: binary-indep binary-arch