r2108: *** empty log message ***
[ctsim.git] / debian / rules
index 394bfe22be7ff0f88f3e267f99377090ce64a9de..ad695b924edff933d3ca49200a449634c9967919 100755 (executable)
@@ -16,9 +16,9 @@ prefix                := debian/$(pkg)
 prefix-help    := debian/$(pkg-help)
 prefix-doc     := debian/$(pkg-doc)
 
-DESTDIR                := $(prefix)
-HELPDIR                := $(prefix-help)/usr/share/ctsim
-DOCDIR         := $(prefix-doc)/usr/share/doc/$(pkg-doc)
+DESTDIR                := `pwd`/$(prefix)
+HELPDIR                := `pwd`/$(prefix-help)/usr/share/ctsim
+DOCDIR         := $(prefix-doc)/usr/share/doc/ctsim-doc
 
 INSTALL                := install
 INSTALLFLAGS   := -g root -o root -m 0644
@@ -28,7 +28,7 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR)
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
        touch configure-stamp
 
 
@@ -58,10 +58,12 @@ install: build
        # Below command also installs helpfile
        ${MAKE} install
        $(INSTALL) $(INSTALLFLAGS) debian/ctsim.xpm $(prefix)/usr/X11R6/include/X11/pixmaps
+
        $(INSTALL) $(INSTALLFLAGS) $(shell echo docs/html/*) $(DOCDIR)/html
        ln -sf $(pkg)_contents.html $(DOCDIR)/html/index.html
+
        $(INSTALL) $(INSTALLFLAGS) docs/ctsim.pdf $(DOCDIR)
-       GZIP=-9 gzip $(DOCDIR)/ctsim.pdf
+       gzip -9 $(DOCDIR)/ctsim.pdf
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -72,7 +74,7 @@ binary-arch: build install
        dh_testdir
        dh_testroot
 #      dh_installdebconf       
-       dh_installdocs docs/html
+       dh_installdocs -A 
        dh_installexamples tools/sample-ctsim.sh helical/sample-helical.sh
        dh_installmenu
 #      dh_installlogrotate