r2108: *** empty log message ***
[ctsim.git] / debian / rules
index 406ea396f0120f3bfc43fcfa451bbd4266dc6c5b..ad695b924edff933d3ca49200a449634c9967919 100755 (executable)
@@ -3,16 +3,24 @@
 # GNU copyright 1997 to 1999 by Joey Hess.
 
 # Uncomment this to turn on verbose mode.
-export DH_VERBOSE=1
+export DH_VERBOSE=0
 
 # This is the debhelper compatibility version to use.
 export DH_COMPAT=3
 
-pkg    := ctsim
-prefix := debian/$(pkg)
-DESTDIR := `pwd`/$(prefix)
+pkg            := ctsim
+pkg-help       := ctsim-help
+pkg-doc                := ctsim-doc
 
-INSTALL        := install
+prefix         := debian/$(pkg)
+prefix-help    := debian/$(pkg-help)
+prefix-doc     := debian/$(pkg-doc)
+
+DESTDIR                := `pwd`/$(prefix)
+HELPDIR                := `pwd`/$(prefix-help)/usr/share/ctsim
+DOCDIR         := $(prefix-doc)/usr/share/doc/ctsim-doc
+
+INSTALL                := install
 INSTALLFLAGS   := -g root -o root -m 0644
 INSTALLDIRFLAGS        := -d -g root -o root -m 0755
 
@@ -20,7 +28,7 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn
        touch configure-stamp
 
 
@@ -28,23 +36,18 @@ build: build-stamp
 
 build-stamp: configure-stamp 
        dh_testdir
-
        # Add here commands to compile the package.
-       $(MAKE) 
-       #/usr/bin/docbook-to-man debian/uffi.sgml > uffi.1
-
+       $(MAKE) all
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-
        # Add here commands to clean up after the build process.
        -$(MAKE) distclean
-       find . -type f -and -name *~ -or -name .*~ -exec rm -f {} \;
+       find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
-
        dh_clean
 
 install: build
@@ -52,24 +55,28 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs
-
-       # Add here commands to install the package into debian/ctsim.
-       # install ${INSTALLDIRFLAGS} 
+       # Below command also installs helpfile
        ${MAKE} install
+       $(INSTALL) $(INSTALLFLAGS) debian/ctsim.xpm $(prefix)/usr/X11R6/include/X11/pixmaps
+
+       $(INSTALL) $(INSTALLFLAGS) $(shell echo docs/html/*) $(DOCDIR)/html
+       ln -sf $(pkg)_contents.html $(DOCDIR)/html/index.html
+
+       $(INSTALL) $(INSTALLFLAGS) docs/ctsim.pdf $(DOCDIR)
+       gzip -9 $(DOCDIR)/ctsim.pdf
 
 # Build architecture-independent files here.
 binary-indep: build install
 
 
-
 # Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir
        dh_testroot
 #      dh_installdebconf       
-       dh_installdocs
+       dh_installdocs -A 
        dh_installexamples tools/sample-ctsim.sh helical/sample-helical.sh
-#      dh_installmenu
+       dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen
 #      dh_installpam
@@ -80,7 +87,7 @@ binary-arch: build install
 #      dh_installinfo
 #      dh_undocumented
        dh_installchangelogs ChangeLog
-       dh_link
+#      dh_link
        dh_strip
        dh_compress
        dh_fixperms