r1851: *** empty log message ***
[ctsim.git] / debian / rules
index 895b8de4731de3171498c5420480a5a0d2df1c67..b1370c9ccecc0cec561016e33c7fb0f633b4efd3 100755 (executable)
@@ -42,6 +42,7 @@ clean:
 
        # Add here commands to clean up after the build process.
        -$(MAKE) distclean
+       find . -type f -and -name *~ -or -name .*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
 
        dh_clean
@@ -55,6 +56,7 @@ install: build
        # Add here commands to install the package into debian/ctsim.
        # install ${INSTALLDIRFLAGS} 
        ${MAKE} install
+       cp -a doc/html $(DESTDIR)/usr/share/doc/${PKG}
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -66,7 +68,7 @@ binary-arch: build install
        dh_testdir
        dh_testroot
 #      dh_installdebconf       
-       dh_installdocs
+#      dh_installdocs
        dh_installexamples tools/sample-ctsim.sh helical/sample-helical.sh
 #      dh_installmenu
 #      dh_installlogrotate
@@ -79,7 +81,7 @@ binary-arch: build install
 #      dh_installinfo
 #      dh_undocumented
        dh_installchangelogs ChangeLog
-       dh_link
+#      dh_link
        dh_strip
        dh_compress
        dh_fixperms