r1851: *** empty log message ***
[ctsim.git] / debian / rules
index bc74840a4fb5cee74ab80d9c16f17d6c148c71eb..b1370c9ccecc0cec561016e33c7fb0f633b4efd3 100755 (executable)
@@ -10,6 +10,7 @@ export DH_COMPAT=3
 
 pkg    := ctsim
 prefix := debian/$(pkg)
+DESTDIR := `pwd`/$(prefix)
 
 INSTALL        := install
 INSTALLFLAGS   := -g root -o root -m 0644
@@ -19,7 +20,7 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-       ./configure --prefix=${prefix}/usr
+       ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man
        touch configure-stamp
 
 
@@ -41,6 +42,7 @@ clean:
 
        # Add here commands to clean up after the build process.
        -$(MAKE) distclean
+       find . -type f -and -name *~ -or -name .*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
 
        dh_clean
@@ -52,7 +54,9 @@ install: build
        dh_installdirs
 
        # Add here commands to install the package into debian/ctsim.
+       # install ${INSTALLDIRFLAGS} 
        ${MAKE} install
+       cp -a doc/html $(DESTDIR)/usr/share/doc/${PKG}
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -64,8 +68,8 @@ binary-arch: build install
        dh_testdir
        dh_testroot
 #      dh_installdebconf       
-       dh_installdocs
-#      dh_installexamples examples/*.cl
+#      dh_installdocs
+       dh_installexamples tools/sample-ctsim.sh helical/sample-helical.sh
 #      dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen
@@ -73,11 +77,11 @@ binary-arch: build install
 #      dh_installmime
 #      dh_installinit
 #      dh_installcron
-       dh_installman
+#      dh_installman
 #      dh_installinfo
 #      dh_undocumented
        dh_installchangelogs ChangeLog
-       dh_link
+#      dh_link
        dh_strip
        dh_compress
        dh_fixperms