r1840: *** empty log message ***
[ctsim.git] / debian / rules
index 79fd21213eebdf823fc775b0581c8d152b54ecbb..bc74840a4fb5cee74ab80d9c16f17d6c148c71eb 100755 (executable)
@@ -15,17 +15,11 @@ INSTALL     := install
 INSTALLFLAGS   := -g root -o root -m 0644
 INSTALLDIRFLAGS        := -d -g root -o root -m 0755
 
-SOURCEDIR      := $(prefix)/usr/share/common-lisp/source
-REPOSITORYDIR  := $(prefix)/usr/share/common-lisp/repositories/uffi
-SYSDIR         := $(prefix)/usr/share/common-lisp/systems
-DOCDIR         := $(prefix)/usr/share/doc/cl-uffi
-
-
 configure: configure-stamp
 configure-stamp:
        dh_testdir
        # Add here commands to configure the package.
-
+       ./configure --prefix=${prefix}/usr
        touch configure-stamp
 
 
@@ -35,7 +29,7 @@ build-stamp: configure-stamp
        dh_testdir
 
        # Add here commands to compile the package.
-       $(MAKE) doc
+       $(MAKE) 
        #/usr/bin/docbook-to-man debian/uffi.sgml > uffi.1
 
        touch build-stamp
@@ -46,8 +40,8 @@ clean:
        rm -f build-stamp configure-stamp
 
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-       rm -f debian/cl-uffi.postinst.* debian/cl-uffi.prerm.*
+       -$(MAKE) distclean
+       rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
 
        dh_clean
 
@@ -58,6 +52,7 @@ install: build
        dh_installdirs
 
        # Add here commands to install the package into debian/ctsim.
+       ${MAKE} install
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -70,7 +65,7 @@ binary-arch: build install
        dh_testroot
 #      dh_installdebconf       
        dh_installdocs
-       dh_installexamples examples/*.cl
+#      dh_installexamples examples/*.cl
 #      dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen
@@ -78,7 +73,7 @@ binary-arch: build install
 #      dh_installmime
 #      dh_installinit
 #      dh_installcron
-#      dh_installman
+       dh_installman
 #      dh_installinfo
 #      dh_undocumented
        dh_installchangelogs ChangeLog