remove use of autoreconf from rules
[ctsim.git] / debian / rules
index f3c8e882351b7418f58a7661b55783459e04e0ba..d0c8a48d5e6d142eb2aeba98d3acd7291c8e7310 100755 (executable)
@@ -29,7 +29,6 @@ configure: configure-stamp
 configure-stamp:
        dh_testdir
        touch configure.in && touch aclocal.m4 && touch configure
-
        ./configure --prefix=$(DESTDIR)/usr --mandir=$(DESTDIR)/usr/share/man --datadir=$(HELPDIR) --with-ctn -with-x --without-lam
        touch configure-stamp
 
@@ -57,7 +56,7 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-arch-stamp build-indep-stamp configure-stamp
-       if [ -f Makefile ]; then $(MAKE) clean; fi
+       if [ -f Makefile -a -f config.status ]; then $(MAKE) clean; fi
        find . -type f -and -name \*~ -or -name .\*~ -exec rm -f {} \;
        rm -f debian/ctsim.postinst.* debian/ctsim.prerm.*
        # Ensure up-to-date versions of config.sub and config.guess